Download

Get Player Controller

Hello all,

I was messing around with a Blueprint trying get player input. I set up a matinee and a trigger. When the player enters the trigger I want to enable input so they can press a key and it will play the matinee. Everything looks right, however when the key is pressed nothing happens. I’m wondering if I’m not calling the player controller in the right way or if I’m missing something here. Any help would be appreciated. Thanks!

http://s23.postimg.org/eid5fjn9z/Blueprint.jpg

Hello!

For the setup you are trying to use, you don’t actually need to do any enabling or disabling of the PlayerController Input. All you’re wanting to do is gate when you can use the Input F key, so you can simply use your Overlap events to toggle a boolean variable on or off and then use a Branch on your Input F event node. It would look like this:

49b347f2379e578f7a3db795f83e38efd6b20d41.jpeg

I should have mentioned this before, I’m using the top down template. What you proposed work fine in a blank project, but it’s not working in the top down template. Any other suggestions?

Try to check project settings ( sound off) - its only suggestion.

Okay, with the Top-Down Template, the default map (which I’m assuming you’re working in) is using the MyController custom Controller. You can see these from the World Settings on the map. In the MyController blueprint, if you go to Defaults > Input, you will see an option for Block Input which will be checked ON by default in this template. This option actually blocks anything outside of this Controller (actually, it blocks anything lower in the Input stack, see the Input documentation for more explanation) from enabling Input. If you un-check this option and Compile this blueprint, the setup I gave you before will work :slight_smile:

Hey thanks Steve! That worked. This is why i was trying to enable input in my example above. Now that disable is unchecked both yours and my examples work. Thanks again!

Just posted a thread myself with this issue and found this one… just unfortunate choice of level to play around with, frustrating that its just one tick box hidden away. It would be great if UE could pick up the fact that your trying to use input events when input is disabled for itself. Or atleast not display them as an option when the checkbox is ticked (:

Ya that’s why I tried to use the enable input node. I thought it would override the settings. Good to know i guess.