Get Platform Name, Get HMDDevice Name should return an Enum

There are two mismatches in these two functions which the return values should match considering they do essentially the same thing… get information about the player’s hardware/software, and return that information.

Instead, I propose that instead of returning the name or string, return an enumerator so that they can be properly “switched” without the need to manually enter the information which could be incorrect. Or better yet, have the function include both the string value as well as the enum value.