Get Font Size Node returns 0,0 for default font

Pretty self explanatory. When we set a font in the node, we got a size. With no font set (aka default), it returned 0.

Hi ,

Unfortunately I have been unable to reproduce this bug, would you mind posting a screenshot of your blueprint setup so I can replicate this? Thank you!

This is the working version, the non working version just had no font set and the resulting 2d vector was disconnected.

Hi ,

Unfortunately the image you posted is too small for me to be able to see what is going on. If you take a larger picture and compress it into a file, then post that on here I should be able to take a look. Thank you!

Hi ,

Thus far we have been unable to reproduce your bug. When we set the font to none it did not return a value of 0,0. Is there any more information that may help us in determining what may be going on to cause your issue? Thank you and have a great day!

Strange, nothing that I can think of. Perhaps it’s the default fonts on windows 7 or some default config issue??

Hi ,

Has this issue continued to persist? I am going to mark this as answered for tracking purposes. However if you are still having this problem please let us know so we can continue to provide assistance. Thank you!

Well, once I got the work around, which was setting an actual font and not the default font (aka leaving it null), I kinda moved on. If you guys can’t reproduce it on windows 7, then i would say don’t worry about it, especially since worse case is that it can be worked around.

I’ve run into the same problem on OS X. If I leave the font field set to (none) on a Get Text Size node, both the Out Width and Out Height are zero. I added a new font (Arial Black 18px) and the Out Width works now.

I’m assuming that the default font is Arial 12px, because when I import a custom Arial 12px font, the Get Text Size node fails to work again.

Get Text Size returns both zero for width and height in OS X using the default font on UE 4.1

LogCanvas: TextSize: No font

Same in Windows.

Confirmed on Windows 8.1. With the default font (none), Get Text Size returns 0.0 for both width and height. This is as of 4.4.0 version.

Hi ,

Can you post your dxdiag’s here? Further, were you able to reproduce this in a clean project with no additional content? Thank you!

Reproduced in a clean project, yes. With custom, blank HUD. Files attached.

[link text][2]

As mentioned above, the issue only persists if default font is used.
What is the font, by the way?

Hi, the problem still exists in 4.4.3

(Both Get Text Size were “activated”)

Hi JimmysBruder,

Did this occur in a clean project with no additional content? Additionally, how do you have your HUD blueprint set up?

The problem still exists in 4.6

I can’t use a direct font variable (workaround) because of several issues
([1][2] [2][3]) that I hope are resolved in 4.7.

Hi everyone,

I was finally able to reproduce this on my end and have entered a bug report, UE-7972 to be assessed by the development staff. It looks like the font is registering a null value, which would explain the 0.0 value as there is no text to get a height and width. However if the default value is supposed to be tiny font that is clearly not what is supposed to be registering. Thank you for your patience while we worked through this nasty bug!