Get error when packaging but no error when launching!

I’m on latest preview “4”.

I’m making an android app.

I can package it as android when “for distribution” is not ticked but when I package the app for android (all, etc or atc1… any) with “for distribution” enabled, I get an error and it stops:
link text

I can launch the game on my mobile from the engine successfully, though there is a problem; I can not go to another level ( I did include the next level/map in the extra packaging settings!).

Hey Danny,

It looks like you don’t have the distribution settings set for Android. I have set up a blank project for distribution, under shipping and packaged it for Andriod (all). Are you able to package an Android project for distribution in a blank template?

Looking forward to hearing back, thanks!

Hi thanks for your reply…

I tried it for both the following and both failed:

Flying example map with starter content: link text

Blank map and no starter contentlink text


I have not touched this one:

Heres the other parts:

Can you please send screennshots of your Android and Android SDK settings from within the editor?

Thank you!

what do you think ?

In your Android SDK, you should fill in the other blank boxes with the directory for example:

  • Android-ndk-r10
  • Apache-ant-1.8.2
  • Jdk1.6.0_45

Once you’ve added in that information, you should have no further troubles with packaging your game. If after you’ve added these in you receive errors, please upload the new log as a .txt file so that we can review them further.


Just downloaded each one and set the folder dir in UE, same problem, packaging stops with an error:

alt text

Hey Danny,

Based on the latest PNG, it looks as though you have a mix of SDK, NDK, ANT and JDK that aren’t in any way paired together. It does not look like you’re using AndroidWorks either. I recommend installing AndroidWorks and pointing all the paths to the appropriate NVPACK paths, this should resolve the issue you’re running in to. I’d also suggest retying in the SDK API level (latest) just to make sure that has been set properly too.

Let us know if you need any additional assistance, good luck! :slight_smile:

Just done all that, still getting an error:

You said a while ago that we would not need to manually set up android in 4.9 ?

[link text][1]

When switching to AndroidWorks, you still have to do the initial set up for the SDK.

Setting Up a Windows Environment for Android Testing

If you’ve already installed TADP/deployed to Android prior to 4.9, please do the following:

  • Rename your C:\NVPACK folder to


  • Uninstall all NVidia tegra and android based software using windows add or remove programs
  • Run the AndroidWorks installer located in \Engine\Extras\Android\ (choose the .exe)
  • Reboot when prompted

Once you’ve done that, then point the SDK to the correct folders, which should look similar to my screenshot provided:

Let me know how it goes, thanks!

so according to this, I should rename my already downloaded nvpack to nvpack_tadp and use this for the engine, I dont get why I have to download it again from the installer inside the engine dir when nothing will be using it?

I’m doing it anyway and will tell you what happens when it’s downloaded.

Didn’t work again, the only difference I see is, yours has no e, mine has an e…Would that make a difference ?
[link text][2]

So, I checked within my Android SDK and the ‘r10e’ is from the older folder, and the ‘r10’ is from the newer folder. Can you please provide us the logs from your most recent package?

Thank you!

my latest is in my reply above, “error.txt”, Should I try find the “r10” ? The new one is “r10e” and they are both in the engine androidworks installer and the androidworks install i got from their website.

Hey Danny,

So I have sat down with our Android Developers and reviewed your logs further. It currently looks like all is working except for the fact that you have the Distribution Settings checked off. So please go back into your project, try to package it as ‘Development’ without the ‘Distribution Settings’ checked off.

However, if you want to package for shipping and distribution, you need to create the key for the store. Please follow this link to learn more.

Let us know if you run into any further complications, thank you!

aha thank you so much :smiley: maybe that option should be removed, it’s quite misleading lol