Download

Get Anim Instance accessed none

Learning from yt tutorials I’ve run into a snag I can’t find info about on google. Using a get on my weapon mesh I get anim instance to play a montage but it reads none. I’m using copied assets from FPS Assault Pack on the market, but building my own blueprints so I can learn how it’s done. I took a peek at the bp included in the pack and it’s doing the exact same thing I’m trying to do so I’m really confused as to why I’m getting none out of my ‘Get Anim Instance’. Any help would be appreciated. https://i.imgur.com/HmlfEk3.png

Post the exact error.

Here’s what it looks like in the log.

Run an isvalid on the mesh prior to playing the montage. Pipe the not valid out to a print string.

Set up just like you said and it executes is valid path to the montage but still reads none for the anim instance. Am I right in assuming the animation instance in this case should be the animbp that I set in the details panel for the mesh and not something else I need to set?

Can go a step further with debugging …

You can also just try Play Montage piped directly from the mesh.

meshplaymontage.jpg

Anim is not valid

how do I get a play montage with the mesh component as a pin? When I drag off the mesh and type montage the only options I see are for anim instance or character?

Let’s try a different approach seeing as you are in a child class.

Begin play -> Mesh -> Set Anim Instance class

Leave the isvalid setup in the event graph.

Nailed it, setting it on begin play fixed it right up. I could have sworn I had tried this but I guess I only thought I did. Is the reason the anim class is not set with the details panel properly because its inheriting? Thanks a ton for the super quick reply.

Another option I can think off is on begin play casting and setting a variable reference to the anim instance.

If you’re using different AnimBP’s for the child classes be sure to “Set” them on Begin Play. Then use the above to set a variable reference to the anim instance.

hmm never mind all that this is a bug I seemed to have caused my self while testing setting it with begin play I forgot I had changed the mesh to the one from the pack and not my copy. The real one works my copy does not I must have missed resetting up a file somewhere after copying it out to work with. Thanks for you help off to go debug my mesh o>