Geometry edit tool not actually editing the shape :(

So I took a video of this bug I was encountering on the Unreal Engine level editor and well, I don’t know how to go around it :frowning:
Here’s the link to said video and I apologize if this is not the place or the right way in going about this problem, and I would gladly re-do it properly. I just wanna get a fix on this D:

Even though you shouldn’t have to do it, have you tried hitting apply after modifying the bsp?

That does look odd. Are you using the latest version, 4.8.2?

Check in your editor preferences - miscellaneous if you have enabled “update bsp automatically” :slight_smile:

Hey just tried what you suggested and it works now, thanks :smiley: