Geometry Cache Animation not working in UE20

I am currently working on a project which has some geometry cache and has been working great until I updated my Unreal from version 4.19.2 to 4.20.0. Now I get this error: “Geometry Cache asset has been emptied as it does not support backwards compatibility”. I tried re-importing the asset, and the character comes in, but the animation seems to not come in because the character remains static even when rendering a movie. I also made sure to have the “running” attribute on, but it still does not play the animation.

Is there something in the settings that I need to turn on in order to get the animation working? I have attached my current import settings.

Thank you in advance!!

I have a similar problem, My geometryCacheActor is now not working after 4.20 upgrade. The actor itself exists, but when dragged into a level is invisible.


I am sorry if this is too late, but I did end up finding a way to get all the animation in using alembics.
I am not sure why but these are the settings that worked for my project. I found that using the sampling type: “Per Frame” ended up dropping some of my frames and the animation looked choppy.

Hope this works for you too