Geo tiff

Hey everyone, I was wondering if from Reality Capture is possible to extract the following data:

  • CRS (coordinate system) / CRS projection?
  • ModelTransformationTag (transform definition)
  • NoData value
  • Height data matrix
    And is this related to geotiff / orthomosaic / DSM?

Thank you for your assistance!

Hi Dani,
RealityCapture is possible to save the coordinate system for ortho/DSM/DTM if the used system is GPS(WGS84) - 4326
For other systems you will get this message:
image
and then you need to set the system manually in the ortho viewer.
But for the models this system is written (you can check it in the RCINFO file). There you can see also the model transformation values:

For the ortho/DTM/DSM is created the TFW file, where some basic information about position and rotation are saved.

No data values are saved.

Height data, too. As DTM/DSM

Hi Ondrej, thank you for your answer!
To summarize, the process consists on, once made sure that the coordinate system is in epsg:4326 - GPS (WGS 84), go to scene 3d → tools → Ortho projection → render, and then Ortho 2d → Export → Ortho projection and export a .tiff file.
Would all the information that I mentioned in the first message included there?
Thank you!

No, for ortho there won’t be heights. You need to export the DTM or DSM to get the heights information.

Ok, thanks.
I tried to export a .tiff from the orthoprojection, but it looks white. Do you know what’s the issue?

Is this ortho or DTM/DSM?
If DTM/DSM you won’t see the colors in the Photo Viewer. Try to open it in IrfanView or in some GIS application.

That is the orthoprojection. With IrfanView looks like this

No, that is DSM.
Ortho is in RGB color, there you can see heights.
Have you used Export Ortho Projection option?
image

Yes, extension .tiff
You can see it on the following screenshots.
Is there something wrong with the settings?

image


This shouldn’t be happening and I am not able to reproduce it. Which version are you using?
Is this also happening after application reset? If you are launching it by Epic Games Launcher, that you can use CLI script with -reset "all" command.

I tried again and it worked, probably was related to the settings. Thank you for your support!