Generic usb controller doesn't always produce responses

Just tried using Generic usb controller (VID_0079, PID_0006) with the RawInput plugin. Everything works fine, except that the buttons press and release doesn’t always produce responses. (Checked this with many hardwares, got the same result with them all.)

I have no problem with the axis though.

Anyone having the same problem or fixes?

I am using the exact same hardware (at least I get the same VID & PID) and am experiencing exactly the same behavior.

Did you find a solution for it?

What I am seeing is that pressing the button (on a successful ‘press’) produces a 1 value on the input, but releasing it does not always reset it to 0 – so it requires multiple subsequent presses to first reset it to 0 before UE4 will recognize another press (a change from 0 to 1).

Different VID (16c0), PID(010a) but same issue.

I have same issue and I just fixed it. Hope this can help you guys. In RawInput \ Device Configurations \ Button Properties, disable button 0, map button 1 to GenericUSBController Button 1, button 2 to GenericUSBController Button 2 and so on.

I guest the error happens because something went wrong in mapping button, mapping axis, perhaps.

Hi. How are you, I think you are making an open world with players who can come and go at any time, I imagine with a maximum. is that correct? I am doing almost the same, you could help me on some issues and I could help you on others. Let me know, see you.

I’m very late to this but if anyone has this issue and the remapping didn’t solve it (in my case it didn’t), I found the cause of the issue, and I have a solution. I have 4.23.1 and the same controller as the original poster. I used x360ce and the problem was, that x360ce already makes the controller to be recognised as an xinput, so by doing this I essentially gave 2 inputs with one button press and this is what caused this seamingly random button miss. So if you have ANY other plugin installed that deals with controllers (like the free directinput plugin), or any emulator software like x360ce try removing/disabling them.

I think most of the time this behaviour is caused by multiple inputs from the same button, I found similar cases with keyboard too after searching for a solution for 2 days. I recommend x360ce it worked for me and with the correct driver even the rumble works fine. I used this one: Universal Joystick Driver for Windows 7, 8, and 10 (2021) (Please hit the Subscribe Button) - YouTube

If you want support for players try this plugin, it worked for me nicely and it supports rumble for non x-input controllers:
https://directinputmanager.com/

(and it works even if you use x360ce for testing the engine supported rumble, just be sure to disable the rawinput plugin, so basicaly the directinput and the x360ce are compatible but neither of them is compatible with rawinput plugin) Hope It helped someone ^^