Download

Generic Shooter: Support Thread

awesome! Thank you Holty007

Hey @Allar it’s been a few months since the last update, are we going to see a new one anytime soon? Perhaps with the release of 4.15?

There will be a 4.15 update for sure, with bug fixes listed on the trello.

Hello @Allar,

I played now some games with friends and I noticed that with each kill the FPS drops. When the server starts the FPS are at 100, after 10 kills at 80FPs after 15 kills at 50 down to 8 FPS in the worst case.
We can recreate this problem anytime with diverent hosts. Is this a known issue and does anyone know how to fix it?

Hey @Allar, I’m having trouble with steam integration. I followed the defaultengine.ini tutorial properly, and i believe have my SDKs organized right. I have yet to get shift+tab to open the steam menu. The closest I’ve got was a packaged game with supposedly the right settings in the ini file, the steamsubsystem plugin enabled, and a

LogOnline:Warning: STEAM: Steam API disabled!
LogOnline: Display: STEAM: OnlineSubsystemSteam::Shutdown()

error in the output log.

But further tampering with some of those config files have also lead me to crashes and having to migrate projects so I could have fresh ini’s and .cs’s (I’m using blueprint only so I know that adjusting those shouldn’t work anyway). I’ve also heard that you shouldn’t have to package to test the steam menu either which would help. I’ve also run into an error when after adjusting the defaultengine and trying to enable the steamsubsystem plugin where the project will crash at 93% on restart. So I’m at a loss in a couple ways, and can’t seem to figure out where I’m going wrong. Also I’m using mac os and UE 4.13. Thanks! P.S. Other than steam integration Generic Shooter has been very fun and easy so far and I’m very happy with my purchase.

EDIT: After a few more hours of trying today I can consistently package the game with what should be the right ini settings and the steam plugin enabled and the output log seems like both my sdk’s are working correctly. I don’t get any issues in the log other api disabled and steamsubsystem shutdown. But attempts at running in standalone will always crash. With the packaged games I’ll open them through steam but still no steam overlay. Any ideas where I could be going wrong or ways to troubleshoot?

Another EDIT! This is my answerhub question with a little more info and logs on my issue
https://answers.unrealengine.com/questions/566927/steam-overlay-not-working-plugin-enabled.html

EDIT:And these are the tutorials I’ve been trying for different packages (they’re mostly the same though)

https://wiki.gamemak.in/genericshooter/communitytutorials/enablesteam4.13

pheeeno: have you enabled the steam plugin under edit>plugins>onlineplatforms?,
recently they have moved a lot of things from game engine to plugins to save file size in packaging games that don;t need specific code,
this had me scratching my head for a while, steam is not enabled by default now.

Yeah I’ve enabled and restarted. When I do standalone will crash but the game will package successfully with a online system steam shutdown warning. And then when I run it through steam the overlay still isn’t there. Here’s a little more info on the issue Steam Overlay Not Working Plugin Enabled - UE4 AnswerHub

@Allar, will it soon be in a sale again?

is there a way to make the charecter from the side like sidescroller? with the ability to aim only up and down?

Hey man, not sure if this helps narrow it down. Certainly not trying to add to frustration but…
I just finished merging one of our projects with the out-of-the-box generic shooter 4.14 version and simply added:
[/Script/Engine.GameEngine]
!NetDriverDefinitions=ClearArray
+NetDriverDefinitions=(DefName=“GameNetDriver”,DriverClassName="/Script/OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="/Script/OnlineSubsystemUtils.IpNetDriver")

[OnlineSubsystem]
DefaultPlatformService=Steam
PollingIntervalInMs=20

[OnlineSubsystemSteam]
bEnabled=true
SteamDevAppId=480
GameServerQueryPort=27015
bRelaunchInSteam=false
GameVersion=1.0.0.0
bVACEnabled=1
bAllowP2PPacketRelay=true
P2PConnectionTimeout=90

[/Script/OnlineSubsystemSteam.SteamNetDriver]
NetConnectionClassName="/Script/OnlineSubsystemSteam.SteamNetConnection"

… to the defaultengine.ini… Then I enabled steam sub system in plugins like Rob Moore there aforementioned… and wallah… steam overlay pulling steam id out of the box… tested in editor and works…

And full compile with zero errors. That being said…
***** I am having an issue where the packaged game does not allow me to click on anything in the menu when it runs… just doesn’t react at all. (Though the steam overlay pops perfectly.) So, obviously I haven’t been able to test how well it pulls the server list and connects this time around… (ive used this project before and have had it working fine in that old attempt)

So, I don’t know if that helps narrow it down but it might be that when you started replacing versions and files and doing that other **** you might have caused an issue… maybe go to a back up before you added steam and try just those two steps i mentioned.
As for my problem…
Does anyone know what would cause it so that I would not be able to click anything on the menu after a 32 bit packaging with zero errors? Any advice is appreciated. If I figure it out I will post my findings.

UPDATE: Well, I checked the menu in the editor preview window and in stand alone… I cannot click on the menu items there either… so apparently its not a packaged issue, but at some point merging the projects I made this issue happen. So, it might make it doubtful that any advice is to be had since its probably specific to something I did. So, I will work on it. But if anyone has run into this issue and could save me some time… again… I’d be much obliged.

UPDATE(RESOLVED): It was because I had implemented my own interface system for doors and melee weapons. In game the interface doesn’t mess with any of the other functionality, (other than menus to click on) but all the regular weapon interact works great so I didn’t realize it was causing issues.
To fix this, I just set my interactwidget to only load if currentlevel did not match “Menu.” It is kind of a band-aid fix and I will have to figure out how to have my interface work alongside allar’s interface in all circumstances, but my issue is resolved here and !*********! as far as Pheeno’s issue or anyone else having trouble, I’d suggest doing only those two things I mentioned above before replacing files and not doing unnecessary work that will make it harder to track down what mistakes were made. It took me 3 mins and those two steps to get steam working, I’d advise not to change unnecessary things. When I added those config lines to the defaultengine.ini … keep in mind that Allar did most of it for you already… the things he had in, I just left… and addended what wasn’t there. Good luck all!
(and if someone wants to reply or send a pm regarding best way to load an interact widget system along side this without conflict go for it! But I will probably work it out on my own.)
Thanks to those who read! And thanks to Michael Allar… One clean **** coder with great flow, logic and talent!
LASTUPDATE: My interactwidget system I put in to work along side the guns for melee weapons and severed limb weapons wasn’t being assigned a controller on widget creation. Easy fix.

Just a question for the people that use this system, has anyone put any large maps or maps with large file sizes on this?

User who goes by ‘docjor’ has some pretty large maps (with vehicles) and it seems to hold up fine.

4.15 Electric Eel Update 03/21/2017

Don’t forget to update itch.io,
thanks…

That’s great to hear, we’ve merged into a project of ours and plan on doing some pretty big streaming levels.

Haha, I thought that was my fault. After I added a physics animation component system I made. Good to know! lol
*Strange bug where network play literally falls apart, i.e. desynced movement, desycned clients, etc. Happening since 4.14, is extremely rare but those who get it are stuck without a fix.
*

Fo’ sho. 4.15 version is up there now too.

4.15 ?! Fantastic, thanks for your amazing product support @Allar !

Got done upgrading to 4.15 and looks really good. I love how your upgrades always have serious improvements. Great job as always, Allar.