Download

Generic Mod uses all memory and crashes

Anyone else having this problem? I thought I corrupted something so I went ahead and re-downloaded everything only to be deeply disappointed when I tried it again, and had the exact same problem. I have 16GB of RAM, and UE4 is using 10GB when it crashes. What gives??? I actually can’t work on my mod without these features.

System specs if that helps at all:
X79 chipset
3930k OCd
samsung 840 evo
980 ti
win 7 64 bit

What exactly are you doing when it crashes, mine seems to always crash when i load the SmallIslandMap and then try to play it in editor… And this has only been an issue since the updated v200.5

I can load TheIsland and play just fine.

If I open the GenericMod map, then hit play, I can watch it eat all my RAM, then crash. I’m honestly glad at least someone else is also having this problem, it’s at least not my PC. How much RAM are you running?

Yeah, I can’t play on TheSmallIsland inside the ADK without a crash either. However TheIsland works fine. As for the GenericMod, why are you trying to use that? It was meant to be a template for building up a new mod from my understanding

Was going to use it as a base for my mod. Turns out that it’s some weird void map, and it just crashes. So for anyone reading this, don’t use that map, just make your own and override primal game data.

The “void” map is only a placeholder so that you can establish your mod. You use that to tell the game, This is how you will play for now on, this is what you will use for a Rex, a bow, etc… If you want to test your mod, use the test map and make sure it has your PrimalGameData and TestGameMode “hooked” in.

The GenericMod map isn’t playable as a level, it is just a shell to cook generic mods that don’t modify TheIsland or add new maps. If you just want a small map to test your generic mods, you can use Game\Maps\TestMap.

If you have not run it before, when you run it the level will try and compile all of the shaders that the map will use for caching it up, if you are having issues with it crashing your page file is probably not set properly and you are running out of memory, it’s quite common for the DevKit to access far more memory then you think it does.

Running the level is not really needed however unless you plan on making a Map, just open it set the world settings to your mod files and then save it and never open it again, just use the TestMap.Level for editing and testing, also don’t edit the standard generic mod make a copy of it and work on that, otherwise updates/verifies will remove your stuff.

This issue has been resolved. I was able to make my own map, assign my own primal game data and it worked fine.

Good to hear null :slight_smile: