fails when building from source on Fedora 36 (Linux)


I’m trying to build ue5 from source (on the main branch).

I ran, and that ran successfully.

I then ran and gave an error:

Setting up bundled DotNet SDK
No usable version of libssl was found

I am using fedora 36

Thank you

Turns out I needed to enable the copr from and install compat-openssl10 with dnf. Hope this helps anyone else on fedora.

I had the same issue on Fedora 36. There’s no version of 1.0 available on the distro any more. They’ve stopped maintaining it in favour of 1.1. This copr worked.

Here’s hoping to a Linux Flatpak!

Anyone how to fix this on Ubuntu 22.04?


Anyone how to fix this on Ubuntu 22.04?

I had the same issue, I managed to fix it by adding the RVM PPA by Rael Gugelmin Cunha and installing libssl1.0-dev:

sudo add-apt-repository ppa:rael-gc/rvm
sudo apt-get update
sudo apt install libssl1.0-dev

Then ./ ran successfully.


Brilliant! Thank you, I ran into this issue too and this solution worked.

Many thanks! Ran into the same issue on Pop-OS 22.04, and this fixed it.

Same in Pop-OS 22.04, mmxgn’s fix solved it.

Thank you so much!! popos 22.04

You saved my Time !! I have so many errors with c++ but your solution do the job now I Can do c++ ! Thanks !