fail on Debian

Hi, I’m trying to build the UE on Debian 7.7, but I have a little problem when I call GenerateProjectFiles :

root@PC-Tavon:/home/tavon/Project/UnrealEngine# ./
Github build
Checking / downloading the latest archives
Started downloading
Traceback (most recent call last):
File “Build/BatchFiles/Linux/”, line 123, in
File “Build/BatchFiles/Linux/”, line 99, in download_assets)
with open(asset_path, “wb”) as f:
IOError: [Errno 2] No such file or directory: u’/root/Downloads/’
Could not check/download binary dependencies !

All the dependencies are installed, the OAUTH_TOKEN is set and i’m in sudo. I’m a newbie to unix but I think I did it well :confused:

Thanks, Tavon.

You should never run as a root user like this, especially if you are newbie to unix, and even if you aren’t. :slight_smile:
UE4 Editor does not require elevated privileges, nor a root user account, to run.

Your error suggests that there’s no folder /root/Downloads/ which is probably expected as root user is not meant to run in a desktop environment. It appears that you’ve su-ed to root user to run

Just run the script as yourself (tavon) and it should find the Downloads folder in your home folder and work as intended.

You can double-check if you have the Downloads/ folder by executing the command: ls ~tavon/ (you should see Downloads in the list among other files and folders in your home folder).

Thanks for the quick answer ! However, I tried to clone and launch the sh with my account, but the error survived. I checked all the homes, there’s no download folder…

You are running some desktop environment, right? There should be a Downloads folder on all Debian based systems (I run Ubuntu). If there isn’t one then create it… :slight_smile:

Well thanks, I just had to mkdir a Downloads folder and it worked ! I just have one final problem, I dont find the makefile that is mentionned on the wiki, and i can’t just make UE4Editor

GenerateProjectFiles should create it in the main folder, so if it doesn’t there must have been an error somewhere during its execution. Check for any errors in .log files in Engine/Build/BatchFiles/Linux/

My BuildThirdParty.log has some errors, I suppose I forget some apt get…

Looks like there’s an issue with Qt4, so you have to make sure all necessary dependencies are satisfied for it.

See this SO link c++ - Error QApplication: no such file or directory - Stack Overflow for some clues.
Also, if that fails, you can remove Qt4 since you already have GTK2/3. You really need just one of those and not all of them.

I don’t know, I downloaded every package that I could find with a link with Qt4, ans the error is still there, I don’t really know what to do…

I am having exactly the same problem after switching from fedora to debian (wheezy/sid). It seems QT4 is simply broken. QT5 is not better. Therefore, I can understand that UE developers do not want to search solutions for this bug called qt… sadly, we are stuck with this problem…

Hi thecr3w,

This is a really old AH post, surely you are not using UE4.5 anymore?

All of us in Linux who are using Qt4 and Qt5 have no problems with it, and alternatively you can try GTK 2 or 3 instead, but this seems to be something specific to your setup.

As mentioned above check the build log for clues, otherwise please try Ubuntu 14.04 LTS, since that is a base standard for UE4 and absolutely works.