Download

GenerateProjectFiles ERROR: Unable to find a valid installation of Visual Studio

**GenerateProjectFiles ERROR: Unable to find a valid installation of Visual Studio. Please check that you have Visual Studio 2017 or Visual Studio 2019 installed, and the MSBuild component is selected as part of your installation. **

This is the error I’m getting when attempting to run GenerateProjectFiles.bat when building UE4 from source. I have Visual Studio 2019 installed and have all the required components mentioned in the README on the Unreal Engine GitHub page. I’ve tried running it without parameters and with the -2019 parameter with no success. Anyone have a fix for this?

Of course, as soon I ask for help, I figure something out. Turns out I didn’t have MSBuild checked in my Visual Studio Installer, so I had to install that real quick and everything worked out just fine after that. This isn’t made mention of in the Unreal Engine README so maybe it should be added at some point.

4 Likes

This worked for me, thanks for sharing this info back!

1 year later and this has not been appended to the Unreal Engine README.

Yep just ran into this as well.

LOL SAME! Thanks!

LOL… Me too :slight_smile:

Same here, thanks a lot.
How to modify VS component you can find in official documentation.

1 Like

LOL! Just happened to me as well!

Thanks a lot! I have got the same problem and it’s done!

from 2021 .
It Worked like a charm.

Thank you and cheers.
b

FWIW, the Visual Studio Installer has a checkbox for “install everything for Unreal development” or some such

1 Like

Thanks a lot !

Thanks @eblade ! :+1: Looks like it is the Visual Studio Installer Workload under Gaming: Game Development with C++ (the description mentions Unreal) :crossed_fingers:

1 Like