GenerateProjectFiles.bat not found Windows SDK 8.1

Windows 7 (x64) SP1; MS Visual Studio Community 2015; Windows SDK 8.1; .Net Framework 4.6.1 SDK - everything is already installed and configured. UE4 source (branch release) downloaded, further doble click to Setup.bat in source folder. Setup.bat uploaded about 4 GB. into UE4 Source folder. Further doble click to GenerateProjectFiles.bat…and…and… over and over error - UnrealBuildTool Exception: ERROR: Windows SDK v8.1 must be installed in order to build this target. GenerateProjectFiles ERROR: UnrealBuildTool was unable to generate project files.

Re-installing of Windows SDK v8.1 not solve the problem. SDK installed in the default directory (C:\Program Files (x86)\Windows Kits). Maybe need install in specific directory?

Hello realesthete,

What version of the engine are you trying to generate project files for? I’m not sure if this is the issue, but try adding -2015 to the GeneralProjectFiles.bat file in the following line:

call “%~dp0Engine\Build\BatchFiles\GenerateProjectFiles.bat” -2015%*

I bolded the command so you can see where it should be placed.

Hello Matthew.

The version of the engine - 4.11.0. Running GenerateProjectFiles.bat by using above line - the error persists.

What of line(s) check by engine in the registry before generating the necessary files?

Thank you for trying that last solution. Can you ensure that the SDK is set up correctly in your environment variables? This is where UBT looks for it. You can find these by following these steps:

  1. Find “My Computer” (Or “Computer” in the Start Menu), right-click it, and select Properties.
  2. Select “Advanced System Settings”
  3. Under the “Advanced” tab, select “Environment Variables”
  4. Find the variable labeled “PATH”, select it, and then hit Edit
  5. Note that there are multiple file paths listed here, all separated by a semi-colon (:wink:
  6. Look for the following path “C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit”.
  7. If that path does not exist, please add it.

We haven’t heard from you in a while, realesthete. Are you still experiencing this issue? If so, have you tried checking your environment variables as suggested in my previous comment? Please let me know the results if so. I’ll be marking this issue as resolved in the meantime for tracking purposes.

Sorry, for late answer, and thx you, Matthew for trying to help.

Well, I’ll say that all “PATH” was and was is correct, but it does’t solve the problem.

The solution(s) to this error:

  1. Reinstallation of the OS or the use of a VM

  2. Reinstallation of the VS with WinSDK

  3. Download the latest version of the UE4 source.

P.S.
Finally, I want to say that the build UE4 was too slow. Really slow…

What is written here-> Building Unreal Engine from Source | Unreal Engine Documentation
about 10 minutes for build the engine - what the machine?

Can we expect in the near future, the full integration of Nvidia Gameworks and SpeedTree for the latest versions of the engine?

And it would be nice if, in addition to the source, for UE4 comunity, Epic Games will provide already compiled engine for save time.

Hello realesthete,

I’m glad to hear that you were able to fix your problem.

As for the build times, please note that it says that it takes 10 to 40 minutes, 10 being a machine that is made specifically for compiling builds. Source builds, depending on if it is a fresh build and if only a few changes have been made, can end up taking quite a while.

We currently don’t have any plans to fully integrate Gameworks and SpeedTree into the base engine, as they are optional features that aren’t needed by all developers.

While it doesn’t allow for custom integration, we do have a fully built version of the engine that can be downloaded through the Epic Games Launcher.