Download

Generate XCode Project doesnt do anything

I just moved my project over from my windows pc to my mac. I already made the provisioning profile, bundlie id, certificate, etc. Im trying to get it on testflight but i need to get it open in Xcode to do that. when i right click the uproject file in Finder and choose Generate XCode Project, nothing happens… how do i fix this?

That’s not the workflow I use.

  1. Sync project to Mac
  2. Go to developer.apple.com and create all of the certificates and provisioning profiles, add your devices, etc. Create both development and distribution profiles.
  3. Go to XCode preferences->accounts and log in to your developer account. Click “Download manual profiles”.
  4. Go to iTunes Connect and create your application using your Bundle ID
  5. Load UE and select the distribution certs for signing. Set your app to “shipping” and “distribution”. Explicitly set your bundle ID (com.mygame.whatever). Build it.
  6. Load up the Application Loader program on your Mac (maybe via XCode) and upload your .ipa file.

Once you’ve uploaded it to Testflight, it’ll go through a review process the first time. At this point you can add individual testers (get them to make an iTunes Connect account) or you can create external test groups. External test groups require ANOTHER round of review the first time and it takes longer, but it’s nice in that you can choose to release builds to them or not even if they’re uploaded to Testflight.

At no point do you need to do anything else in XCode. You don’t even need your project open.

The main thing I use XCode for besides downloading the certs is to deploy already-built dev builds to the device, since the launch button doesn’t deploy everything.

1 Like

I facing the same issue, i’m working in 2 projects and the contextual menu option fails on both (same engine version), but for the first one i able to generate the xcode project running the GenerateProjectFiles.sh command, sadly it does not work in my second project. I tried to fix this issue since few months without any luck.

In case it help you, open terminal and run:

sh “/{PATH_TO_ENGINE}/unrealEngine-4.21.2-release/engine/build/batchfiles/Mac/GenerateProjectFiles.sh” -project="/{PATH_TO_PROJECT}/{UPROJECT_FILENAME}.uproject" -game

2 Likes

I followed the stemps from Antidamage above and it worked.

2 Likes

cmd works great, thx a lot

Hi, I have a similar issue here, but the terminal command does not work, it always tells me that :

“Unable to find project file based on argument” and the file path I wrote.

Now I tried to copy the project elsewhere, to be sure I did nothing wrong I copy the path by ctrl alt click on it to copy the project file path but nothing changes. If I tried to cd + the path copied, it works.

If I try to directly generate xcode on the project files it just opens a terminal windows and does nothing else.