Generate project files not working (no crash or errors)

Im attempting to build 4.10 from source (using the release branch from github) but im running into a problem when i try to generate project files. The cmd pops up and says its setting up project files, but it never finishes (current attempt has lasted over an hour), and i get no error messages or anything to indicate whats going on. Iv tried the whole process from scratch a few times today in case i messed something up (i did prematurely end the setup the first attempt by accident so had to restart) But its always getting stuck at the same issue. Not sure whats going on as iv built from source before in 4.7 and 4.8 with no problems.

Any help or suggestions are much appreciated!

Hey StuartP-

The release branch is currently set to 4.11 Preview 5 due to an oversight while pushing a build to Github. To get the 4.10 branch you can click the drop down next to Release and choose 4.10. You can also use the following link and choose between 4.10.0, 4.10.1, or 4.10.2.


Thanks for the info , I’v dowloaded the actual 4.10.2 release now and tried again, but unfortunately the problem is still persisting.

I’m currently in the process of reinstalling Visual studio (using 2015, disabling update 1 and checking C++ stuff is ticked) to see if thats causing the issue

Hey StuartP-

I just wanted to touch base and see if you’ve had the chance to try reinstalling Visual Studio? Let me know if you have any further questions.

Hi ,

Iv managed to reinstall visual studio a couple times and the problem is still happening exactly as before. My first reinstall i just enabled the C++ stuff, but that didnt work so i tried installing everything in the second go in case i missed something, but still nothing :confused:

Im not really sure what else to try at this point, i know its not the zip download as iv downloaded it multiple times to ensure it wasnt messing up there somehow, as well as trying out a different engine version (4.10.1). I also know its possible to get the source build working on VS2015 as we have another computer in the office which has it working, but i havent been able to figure out what the difference is here.

It may be that there is another instance of the Unreal Build Tool (UBT) running that is interfering with GenerateProjectFiles.bat. If you see an instance of UnrealBuildTool.exe in the task manager please try closing the process then running GenerateProjectFiles.bat. It may be best to fully restart the computer to ensure that any instance of UBT is killed before running GenerateProjectFiles.

Ah i did notice this on one of my attempts - where i got the error for there being another instance of it open already. I usually have to restart each time to be able to close the process, but GenerateProjectFiles.bat still isnt finishing when i make sure theres none of the process already running

Is it usual to have this many versions running in one fresh attempt?


You mentioned being able to compile 4.7 and 4.8 previously. Can you try compiling 4.9 or 4.11? If you run into the same error then please try running GenerateProjectFiles.bat for 4.7 or 4.8 again.

You also mentioned that the batch file gets stuck at the same point each time. Can you post a screenshot of what you see when it freezes?

Can you also download the attached file. If you remove the “.txt” extention and run the batch file it will pull information about your Visual Studio installation and create a new “Info.txt” file in the same location that the batch file was ran from. If possible, please include the Info.txt as well.

Batch File

Hi , I tried 4.11 but still nothing, had to install VS2013 to do 4.9 and the ones below but all 3 of those failed as well.

The point it gets stuck is just the first part of the generate project files as far as im aware, it never gets past this first line

I have run the batch file you sent me and attached the info.txt it provided. I hope this helps!


[link text][2]

Hey StuartP-

Just to restate, you did the following steps:

  1. Downloaded the source zip folder from Github
  2. Extract the zip folder content to your computer
  3. Ran Setup.bat from the unzipped folder
  4. Ran GenerateProjectFiles.bat from the unzipped folder

This is the point that it becomes unresponsive, correct? You’ve also tried these steps for multiple engine versions, yes?

I’m still investigating this issue and attempting to find other possible solutions. Let me know if there’s any additionally information you can provide about this issue. Additionally, since you mentioned having successfully installed the 4.7 and 4.8 source can you attempt to re-download / re-install either of these (in a new location of course)?



Yes this is all correct, i have also reinstalled visual studio 2015 and 2013 a number of times, where the current setup has every check box enabled.

I’ll give 4.7 and 4.8 another shot in a new location and get back to you with the outcome

UPDATE: I re-downloaded and tried re-installing 4.8 and 4.7 but both still failed to generate project files in the exact same way

I am having the exact same Issue as the OP. No matter what I try, reinstall (several times) release of 4.10, and 4.11. I verified the C++ thing in visual studio 2015 community with a fresh install… The generate project files.bat file sits there indefinitely. In task manager, there are no instances of the build tool running, only the cmd.exe window is logged. However, if I try and delete the engine source code, the build tool executable is still in use after closing it with the “x”.

If 4.7 and 4.8 built previously but won’t build now then the .bat file may not be the issue. Can you check your anti-virus software to make sure it is not interfering or blocking anything from Epic Games or Unreal Engine?

some good news - I added an exception for my source folder in my anti-virus and thats allowed the GenerateProjectFiles.bat to get further, however its now stuck at 0% writing project files.

Are there any other path exceptions that i might need to add?


UPDATE: Better news! - I managed to get project files to generate at last. I added an exception for visual studio which led to me getting an error to do with being unable to access EnvVarToXml.exe, and at this point i tried running it with antivirus totally disabled, and that seems to have done the trick!

Im now building in visual studio (2013, got a wierd thing with 2015 telling me my community license expired somehow, but if its working in 2013 im happy) but all seems to be going smoothly

Nice find! This solved my problem as well. I added Visual studio 2015 community and the epic games source folder to the exclusion list and it generated the files. I am using Avast for my antivirus if that helps.

I’m also using avast, so it might be a relatively common problem for avast users

Another Avast user here who was bitten by this. Putting my projects folder that has all things Unreal in it along with my VS2015 folder under exclusions fixed my issues.

I feel like this might’ve been a recent Avast update. I had built the project files for 4.9 and VS2013 with no problem a month ago. But we pushed an engine update for work so everyone needed to upgrade to VS2015. My personal machine couldn’t ever build the project files but I’m the only one trying with Avast.