Gear VR Fix Black Screen UE4 4.11.2

Hey everyone,

On UE4 4.10 I had a Gear VR application loaded on my phone (Note 5) that functioned properly (it was just the FPS Shooter starter project). I recently made a new project in 4.11.2 and when I build it on my phone, the application only shows a black screen with a small white x in the bottom corner. Anyone have any suggestions on how to fix this?

Previously I had the Gear VR plugin only enabled, I have Mobile HDR disabled. The target and minimum SDK is 19 and the NDK is set to 19 as well. I have checked the box to build for VR. I have tried a lot of configurations and have been rebuilding to see which would work based on other forum questions and answers but nothing seems to help. Any advice or info has been greatly appreciated!

Hi Coldstryke,

We don’t specifically have a Note 5 to test on, but on my Note 4 and a couple of other devices I have here I have not run into the issue.

Some things to try:

  • Can you try packaging your game with 4.12 Preview 5 that is available now on launcher?
  • Are you able to launch the game on the device without GearVR enabled?
  • Have you properly setup your OSIG file and placed that in Engine/Build/Android/Java/Assets?

Thank you!


Same here and nothings seems to work for me! 4.12 Preview 5 behaves the same. Launching without gearVR enable works perfectly. OSIG is okay and not the problem (because that triggers an error, TBH - if this was the problem the apk would not launch on Oculus.

Hey Tim,

I actually realized the other day that I didn’t have the OSIG file placed in the directory for 4.11 but I did for 4.12. Added that, packaged it and started working perfectly on my phone. The app loaded very fast!

Only problem is that it takes a bit more time for development because I have to re-package it then send it to my device every time I want to test something with the GearVR. I can’t seem to get the “Launch” option directly to my phone to work though (has the same black screen issue) whereas packaging works great.

Thanks for the advice, I really appreciate it!

My issue seemed to be that I didn’t actually have the OSIG file in the 4.11 engine directory. I must have forgotten to add it after I upgraded from 4.10 to 4.11. I also turned off the option for “Package game data inside .apk?” Maybe that will help!

Not sure on the launch issue. I’ve not had that one myself in my many many test projects. I have found that the launch buttons sometimes would work where the package option would fail though.

Here are a couple of options to try:

  • Disable the GearVR plugin and see if you can launch with it working.
  • Try using a blank project to see if you get the same issue?

You can also do the following to get the Log files from the device that may indicate where the failure is happening for the launch onto your device.

  • Attach your phone to the computer
  • Go here: C:\NVPACK\android-sdk-windows\tools
  • Open up Monitor.bat
  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\NVPACK\android-sdk-windows\tools\lib\monitor-x86
  • Open up Monitor.exe
  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they’re highlighted.