Download

GDC2017 Cloth Paint, not in Github4.16?

I can’t seem to find the new cloth mesh handler and painting tool system showcased at GDC this year, in current 4.16 build? Am i missing it somewhere, or is it just not yet available to play with? :stuck_out_tongue:

Also is there any documentation on how to create control rigs with the new system similar to AllRightRig?

edit: actually i can’t find the new rigidbody node which was the reason i looked intoo current 4.16 :p, guess there’s only the Control Rig feature currently available?

Yea I tried as well and the new cloth editing is definitely not there and it doesn’t matter what branch you compile. I even tried to find it in editor settings among Experimental features but no luck.

Oh well, thanks for sparing me the time and effort then ! ^^

I guess that stuff is all in Paragon’s repo for now, nothing have been pushed to engine git yet.

Edit: Here’s a link to what the topic is about (I think) UE4 Animation and Physics Technical Showcase | GDC 2017 | Unreal Engine - YouTube I hadn’t seen the presentation about the clothing pipeline before so I was curious.

Edit again: The clothing editor module appears to already be in the master branch on Github.

Dev-Framework just merged, so like n00854180t said, it should be in main now (assuming it is dev-framework, where this type of feature would normally come from)

Cheers!

Exactly what i was referring too indeed !

Awesome :3

did you manage to get the master branch to work i tried but i get a leapmotion module error

I’m about to start compiling :stuck_out_tongue: Not sure you needed to start a new thread of the subject btw ^^…

I compiled the master branch 4 days ago without any issue.

I’m afraid the master branch isn’t intended to be used in production, i’ll take any working feature as a gift from the future lol.

i tried to compile the branch but i got a leapmotion plugin error

I don’t know what you intend to do but 4 days ago i managed to crash the engine 4/5 times.

i just want to test the cloth paint with my cloak for my character

4.16 is compiling , trying to find the clothing now :stuck_out_tongue:

There’s the section selection but i don’t see the “create clothing from section”

You may need to enable it in the experimental features menu.

Man of the hour, Hats Off Gentlemen

I can paint the min distance parameter, the green dot at the start of the clothing, but can’t find the shortcut to toggle max distance painting for the red dot :3…

maxime what branch is that in?

It’s in Master branch for a couple days.

ahh okay, i’ll try build it, i tried last night and it didnt even launch i kept getting a leapmotion error i’ll give it a shot, unless you can upload the zip you downloaded somewhere :slight_smile:

Pulled from the .16 branch today, can’t seem to find the the Cloth tools in the preferences? Wondering if I did anything wrong