Download

Gap appears when merging static meshes, that are rotated

Good day to all!

The Bug: Whenever I try to merge a couple of modular static mesh actors from my scene, with the Merge Actors pop up menu, using the third option (Harvest geometry from selected actors and merge them into an actor with multiple instanced static mesh components), then whenever the static mesh actors are rotated, a small gap appears in between them. I tested this also on the basic cube instead of my own models, and the same thing happened, I also tried doing this in 4.27, but the bug is also present there.

My Question: Has anyone come across this before, and have you found a solution?

I also tried the other merge options, and they do work, however they make a whole new model, which would not work for my game as that would increase the size of the game quite a lot (as I’m using it to merge a lot of modular buildings), while merging actors into an actor with multiple instanced static meshes seems to work just as well, performance wise, and is even somewhat customizable after the merge.

It would be very beneficial for everyone I imagine if we could get it to work without making these small, but noticeable gaps, between our modular meshes.

I hope we can find a solution for this, or get the kind folks over at epic to look at it,

Tim :slight_smile:

if this is what i am thinking look into masking in the textures. Are these gaps small white slices? If so, look into masking the materials to stop the slicing where they come together.

Is it like this? I know this is from the older engine, but shows the effect i am talking about.
https://docs.unrealengine.com/udk/Three/TessellationDX11.html#UV%20Seams

Here are two screenshots, the first one showing the two separate meshes before the merge, the second shows the meshes moved slightly apart from each other creating the gap. Or at least I think they have moved apart, it might be something else.


Hi! sorry for the late reply. I don’t think this is the same problem, its not a white slice I’m afraid, the meshes actually get moved apart creating the gap in-between them, at least it seems so. I have posted two screenshots displaying the problem