Gamepad + OnKeyDown = Too many Stick Events

I just added Gamepad support to my GUI (It has no mouse\keyboard). When I use OnKeyDown to read the D-Pad presses I get reiable movements around the grid. However if I use my right stick a single flick of the stick as quick as I can yeilds often either two Right key presses or usually a right followed by a left as the stick ‘flicks back’.

This seemed reasonably similar to a deadzone problem as I could ignore the tiny counter movement, but even at 0.5 the axis controls (Project Settings \ Input) don’t seem to make any difference.

I was thinking I just need to ignore any event that comes in within say 100ms of the first one, while in the GUI. Then just fiddle the settings to something that is responsive, but doesn’t produce doubles.

Is there a better way to do this? This game is gamepad centric so I can’t afford to have crappy controls.