Gamepad not working

Hello,
I have bought uRage gamepad. It is not working with ue 4.7. Are their only specific gamepads works with Unreal?

Xbox 360 wired gamepad works fine.

I’ve the same issue, gamepad Logitech Rumblepad 2, works fine on all games. It just doesn’t seem to work with the unreal engine. I use the actual version 4.9.

Same issue. Just doesn’t seem to work.

I can copy that! Neither actions nor buttons do work. Any help is appreciated!

Can you all Play in Editor and then enter the console command showdebug input. Then start pressing buttons on your controllers and see if any inputs appear (you can press keyboard keys to see how it’d display).

If it registers any input at all, you’ll need to set those up in Project Settings>Input. If nothing registers and you’re sure your drivers are up to date, we can go from there.

-Matt W.

Hi, first, I used the UE4 driver template to test it out, so yes the gamepad input is activate in the project settings, tried with the console command, and nothing shows up. I also installed the newest driver for my gamepad, still, it doesn’t change anything.

Hi everybody,

So as the editor only supports xinput, you’ll need to set up x360ce for your controllers to be recognized.

Please see a previous post about this: Logitech RumblePad 2 USB not working in Editor? - AnswerHub - Unreal Engine Forums

-Matt W.

Dumb suggestion but try clicking on the game after you start it and then check if your controller works. I have a third party controler with x input and it works fine.

I ran into this issue as well recently. It’s actually a pretty simple fix. Thanks to this thread! Here is a quick tutorial to walk you through the setup:

come on that’s your solution ? my gamepad is detected by so many games why would’nt it work wigout the xbox game pad emulator

i am facing the same issue. let me know once its resolved or anyone knows what needs to done?

You need to enable the Raw Input plugin. They have some documentation about the whole thing here:
https://docs.unrealengine.com/4.27/en-US/InteractiveExperiences/Input/RawInput/

I confirm that gamepads works,
for some reason it seems gamepad starts to work after you left click on screen.