Gamepad not working when Connected to Steam

Is anyone else having an issue where you can’t use a gamepad while connected to Steam? If I close steam out and run the game in editor or packaged I get the gamepad functions back. I’ve tried enabling and disabling the Steam Controller Plugin but haven’t come across a fix for the issue.

So as soon as I comment out the Steam Online Subsystem additions to the DefaultEngine.ini and restart my project I have no problems with steam and using controllers. This includes being able to use the Steam controller. Is anyone else experiencing this issue? How do I fix this issue? Is it related to using the test appid 480?

[EDIT] 's answer is less cumbersome and the solution you should follow.

Hello there,

I actually stumbbled across the exact same problem recently. It is caused by Steam trying to load (and override) a default gamepad configuration at launch. To prevent that, here are the steps I followed :

  1. (Assuming you use appid 480) Install Spacewar on your PC. To do so, press Windows key + R , then paste steam://run/480 and hit enter. This will install the game.
  2. In Steam, click on the Big Picture Mode button in the upper-right corner. This will open Steam in Big Picture Mode in full screen.
  3. Click on the Library button.
  4. Select SpaceWar.
  5. Click on the Manage Game button in the left-hand column.
  6. Click on the Controller Options button.
  7. Click the Steam Input Per-Game dropdown box.
  8. Select Forced Off.

(Instructions taken from this page : )

Then restart your game / editor and you should hopefully be able to use your gamepads.

Hope it helps,


My game in steam does not allow users to use gamepads, how can I fix that? when I buy it and play it on my pc the gamepad works for me fine. Thanks!

That’s not a solution, are we supposed to ask every customer to do that?

They want you to join SteamWorks before they let you define your own gamepad config

They want you to join Steamworks before you can do your own gamepad config.

This seems to happen because of Steam’s Big Picture controller system eating your inputs.
By default, SpaceWar (appid 480) has no controller configuration set, so you have to configurate it on your own.

The way I fixed this:

  1. Launch your standalone game with steam subsystem on
  2. Open the Steam overlay
  3. In the top right corner, click Controller Configuration
  4. Click “Browse Configs” on the bottom of the Steam Controller Configurator
  5. Choose Templates → Gamepad
  6. Apply Configuration

You only have to do this once from what I can tell.


Hey, thanks man!
The gamepad suddenly stops functioning after integrating Steam SDK got me panic for a moment.

Now we can not deny any possible option how do i fix connections to wireless displays in windows 10 which I read for make it very simple.

you arent supposed to use the spacewar appid if you are distributing your game to actual customers…

I concur that this is what you have to do when you are developing using appid 480 (SpaceWar).

I now have my game on Steam and I believe I set it up to support the gamepad; however, using a testing key and installing the game via Steam I get the following:


I assume it is a Steamworks setting. Yes?

Any clues as to what checkbox, or ???, I need to select would be much appreciated.