gamepad not working in unreal

hi i have gamepad microkingdom 890s

i want to use this gamepad in my project, but not work in unreal, but it works well in windows 10,

anyone here can help me to make the gamepad can work in unreal?

how to set the gamepad so unreal can recognize it

thank you very much

Gamepad not working in the editor or the preview?
If it’s not working in the preview: go in Edit, Project Settings, Input and change the input for your gamepad

Did you findout how to play with gamepad in android

I am using xbox 360. Controller. Working fine in editor but the dpads are not working in android.
Same issue with ipega pg 9023 controller.
The other keys are working fine but the dpads are not working.

I had a similar problem, and I checked the following to get things going.

  • I had recently plugged my Xbox One controller in, so possibly it didnt detect right away

  • Can you move around in the editor view (not playing the game) with the controller? It should fly around like WASD

  • When you start the game, have you clicked on the window to focus it so it takes input?

  • Try running the game outside of the editor and see what happens.

  • Open the blueprint while playing your game which listens for controller input and check to see if connections are firing.

  • You may also have an event which consumes the input and isn’t sharing with other event calls

Hope that helps :slight_smile:

The DPad I’d suspect is interpreted differently maybe when on an Android device. You’ll probably need to go digging through documentation of controller inputs for Android and add them as controller inputs in your Project Settings → Engine → Input

You may even need to create your own input code to handle it. Where you start with that I dont know sorry :\

Here is a tutorial that should work setting up any gamepad or joystick in Unreal Engine: