Gamepad input registers on both Authority and Remote

Using this setup in a simple listen server/client 2 player setup using standalone play;

  • Pressing E on the server prints Authority
  • Pressing E on the client prints Remote
  • ** Pressing Face Button Left on the server** prints Remote on Remote, and always Authority on the Server
  • Pressing Face Button Left on the client prints Remote on Remote, and sometimes Authority on the Server

Multiplayer settings;

I wasn’t sure if this is a bug or if gamepad input by design is handled differently, but to me it didn’t make sense so posting it as a bug report.

Hi bzxo,

Here is the results that I get each time:

  • Press E on Server = Authority

  • Press E on Client = Remote

  • Press Face Button Left on Server = Authority

  • Press Face Button Left on Client = Remote

This is what is expect to see. But the Gamepad Remote sometimes printing Authority, that you are seeing, isn’t expected. Could you upload a small test project or test your exact same setup in 4.11.2 or 4.12 Preview to see if it still occurs there?

Hi bzxo,

We haven’t heard back from you in a few days, so we are marking this post as resolved for tracking purposes. If you’re still experiencing this issue, please feel free to post back here with additional information to reopen the post.



Hey TJ, sorry missed this. Unfortunately I don’t have 4.11 or 4.12 but I made an empty project with the problem which you can DL at [edit: changed to dropbox link;]

Open the GamePad_DoubleInput\GamePadBug map, launch 2 standalone plays and press E in both windows, then GamePad Left (X). At least for me, they don’t respond in the same way. with pushing the gamepad button firing in both windows and E firing in just one.

For some reason I keep getting a “404 Not Found” error when I try to click your link. It’s possible that our firewall is blocking me. Could you post the project on Googledrive or DropBox?

Or it’s it’s under 5 MB you can upload it directly here.

Ah, uploaded it here.

Hmm, this is strange; I don’t see the issue on my end. Both the E-key and the X-button on the controller work in the server and client windows.

I’m thinking you could have either a bad install of the engine or (kind of a long shot) maybe it’s a hardware issue?

  • I would first try verifying the engine version. You can do this in the Library tab in the Launch and click the yellow arrow on the engine version.

  • If that doesn’t work, maybe try another keyboard. Seems less likely, but just to be sure.

  • As a last resort you could try reinstalling the engine.

If none of that works, please post your Dxdiag (system specs) so we can test on a machine with similar specs.

Hey TJ, I verified the engine and am still getting the same error.

To clarify, here’s a video of what I’m getting;

I first press E on the keyboard in each of the two windows, then do the same with X on the gamepad.

I’ll try reinstalling the engine within the next day or two!

Just to clarify further. Pressing E works as expected but the gamepad is registering on both the Client and Server simultaneously. Is that right?

What type of gamepad are you using?

That’s right. I’m using a wired Xbox 360 controller.

Hi bzxo,

Just checking in. Any luck after reinstalling?

FYI, I tested with an official Xbox 360 Controller and that worked correctly for me as well. Are you using another brand?

Hey TJ,
I attempted again using the project I sent you earlier, this time using 4.12, and am still getting the same issues :confused: seems like it’s something on my computer, I’ll see if I can try it on another one in the coming week.

Edit: nope, using the official Xbox 360 controller - both older white one and brand new black one. Wired.

Hi bzxo,

No rush or anything. I’m just going to comment here so this post will resolve for the time being. When you have time to test this on another PC, just post comment here with your results to reopen the post.