Gamepad Input - Left Shoulder Broken

Hello.

I’m not sure if this has been reported yet but the left shoulder button doesn’t seem to be working anymore.
I moved from 4.12 to 4.14 and after I ran through all my blueprints and fixed the issues I went and played my packaged build and noticed the left shoulder function not working at all.

Inside the editor it seem to not fire anything at all and my inputs are all correctly implemented (I checked to make sure my custom input command was still there)

I also had another report from a friend who alerted me in the first place.

Sorry for the bump, has anyone else experienced this issue yet?

Hey Joure-

Have you reproduced this behavior in a new project? I tried creating a project and was able to directly use the Gamepad Left Shoulder event as well as bind the button to an action and call that action event. If you can reproduce the issue, please provide the setup steps and/or the sample project to help me investigate the issue locally.

Left shoulder works for me in 4.14…but I only migrated from 4.13 in this particular project.

Sorry for the late reply. I will have to take another look, I’ve been using the UMG gamepad blueprint from Rama so maybe there’s an issue there. I will try to confirm if that’s the the case and if so I’ll report back to him.

Please post a screenshot of the setup you’re using to call your button input. Also let us know here if you’re able to use the button without using the gamepad blueprint. You should be able to test easily by creating an actor blueprint and adding “Gamepad Left Shoulder” and “Print String” nodes. In the Class Defaults for the blueprint, you can set “Auto Receive Input” to Player0. Then, when you place an instance of the blueprint into the level, you should be able to press the shoulder button and see the Print String message.

Hey Joure-

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Cheers

Doug Wilson

Hi so sorry for not having replied yet. It seems to have somehow sorted itself out. I’m honestly not sure what fixed it, or if it was truly broken in the first place but it seems to be working now.

Thanks for the support !!!