GameInstanceSubsystems not Initializing in upgraded project

Hi, I’m making a plugin. Inside the plugin’s module is a GameInstanceSubsystem subclass.

I started working on the plugin in ProjectA, then copied the plugin source to ProjectB.

Unfortunately, the GameInstanceSubsystem only initializes in ProjectA. It doesn’t initialize in ProjectB.


  • Created from 4.26 source build (or 4.26 from Epic store changed to source)
  • “EngineAssociation”: “{E2D6E774-46BF-7EDB-3F3B-B190DCDB23D5}”,
  • My GISS works here

ProjectB is this repo (4.17), upgraded to 4.26 source build.

I created two other GameInstanceSubsystems in ProjectB using the Editor’s new class UI:

  • One in plugin module, other in the game’s main module
  • Generate Visual Studio project files
  • Open and run project
  • No expected output.

The two new GISS’s were implemented like this:

// Fill out your copyright notice in the Description page of Project Settings.

#pragma once

#include "CoreMinimal.h"
#include "Subsystems/GameInstanceSubsystem.h"
#include "OtherGameInstanceSubsystem.generated.h"

class COOPPUZZLEGAME_API UOtherGameInstanceSubsystem : public UGameInstanceSubsystem
		virtual void Initialize(FSubsystemCollectionBase & Collection) override;
	virtual void Deinitialize() override;



void UOtherGameInstanceSubsystem::Initialize(FSubsystemCollectionBase & Collection)
	UE_LOG(LogTemp, Log, TEXT("Initialize UOtherGameInstanceSubsystem ..."));

void UOtherGameInstanceSubsystem::Deinitialize()
	UE_LOG(LogTemp, Log, TEXT("Initialize UOtherGameInstanceSubsystem ..."));

I poked through the build files and didn’t see any big differences.

I tried disabling the OnlineSubsystemSteam, but I’m really just flipping switches at this point.

How do I get these GameInstanceSubsystems to initialize?


I made a new project in 4.26 and started working on the plugin there. It’s likely an upgrade issue in UE or the changes I made upgrading the project. I didn’t do the work to file a bug, and I don’t think UE would do the work to fix it. Check the repo if you’re interested.