Download

Game Stutters Occasionally

I’m new to UE4 and game development, I’m working on a project right now and for some reason when I test it the game will sometimes stutter or hitch. Not sure what the right word is. Sometimes it’s not bad but others it will freeze for a second before working normally again. I’m using 4.24.3 and not too much going on in the level. Any ideas to fix this?

What are your computer specs?

Windows 10

GPU:
nvidia quadro p5000

CPU:
Intel(R) Xeon(R) CPU E5-2667 v3 @ 3.20GHz

12 GB RAM

It’s usually pretty smooth sitting at 120 fps. But will just have moments where it stutters or has a splitsecond freeze that is jarring and it would just throw the player off

The only way you will find out what causes the hitch is by profiling your game.

Do you use level streaming?

I only have one map atm it is a fairly new project so I haven’t looked into level streaming. I noticed online some people were having similar issues with 4.24.3. When I have a chance later today I’m going to create a new template project and see if it still happens, then install the 4.25 preview and see if there is any change in performance if it continues in the new project. I’ll post an update later when I have time.

So I created a new fps template project and it persists in the new project. I installed 4.25 preview and see it there as well. Is this just an issue with the engine atm maybe?

I don’t have this issue. Using 4.23.

  • Windows 10
  • Intel i7 @ 3.6ghz
  • 12GB Ram
  • PNY GTX 1650 4GB

EDIT: Your graphics card is easily better than mine. Perhaps its a CPU issue? I know I used to have issues like this when i had too many background processes enabled. I disabled Hardware Acceleration on mostly all my apps. So Discord, Chrome, etc, don’t have HA running. This helped me. As well as restarting my computer when I noticed this issue appearing.

I don’t think it’s a CPU issue the only thing I have running in the background is chrome playing some music on youtube. I haven’t tried using 4.23 yet though. Tomorrow I’ll install and test when I’m home.

Alright so I installed 4.23 and tried out the fps template again. Same issue and it actually seemed worse on that version :frowning: