Game Stopped Working in Linux after upgrade to 4.8

So I upgraded my project to 4.8 and went through all the code to make sure everything was fine. I then packaged the game for Linux and Windows (64 bit and 32 bit) and then ran some tests. The game client and game server works perfectly on Windows … however on Linux only the game server works.

When I try to run the game client , a black window appears and after waiting for almost 10 minutes, nothing else happens. The machine becomes almost impossible to use and nothing I try will allow me to sort it out. Sometimes I am lucky and I can Ctrl-C the game to kill it.

This same process worked perfectly with my project in 4.7.6 … so I am not sure what the problem could be.

Does anyone have any suggestions I can try?


I am going to try that. Will let you know.

Does packaging an example project work for you?

Cool! Probably just steps 3, 5, 6 and 7 would be enough, but I’m glad this solved it for you!

I managed to get this fixed, basically I did the following:

  1. Completely removed UE 4.8
  2. Completely removed the source code
    for UE
  3. Cleared all build and intermediate
    folders for the game
  4. Re-downloaded the source code for
  5. Did a clean and rebuild
  6. Re-linked my game to the new source
    code build
  7. Packaged my game for Linux

Some of the steps are probably not necessary, but I did them to make sure I got no conflicts or issues. I know have a working Linux build for my game client … yay. 8-}