Game Settings Not Saving/Applying

Hello, when I try to change the screen res or FPS limits, anti aliasing etc…it never applies the changes?

I tried to do it in it’s simplest form (GetGameUserSettings>ApplyResolution>ApplySettings) and in it’s simplest form it still doesn’t work. Why?

PS:I am playing in standalone not PIE.

I appreciate any help.

I’ve been having trouble with similar issues, and in looking at your blueprints, it appears that your “Lower AA” piece wouldn’t do anything to the game settings because you never use variables from the Game User Settings. The “Lower Resolution” piece doesn’t reference Game User Settings at all, but that appears to be intentional based on the “Apply Res” piece.

What I would expect to see running this is that pushing LowerAAButton does absolutely nothing, and ApplyResButton will lower the screen resolution iff LowerResButton was pushed first and the resolution was not already at its minimum, but the string “saved res” will be printed regardless.

So, what you need to do is make the LowerAAButton use a variable from Game User Settings, but if the ApplyResButton isn’t working either, then that doesn’t solve your problem. You should probably rephrase the question anyways, though, to make it more clear wherein the actual issue lies.

Thanks for the reply, I think it’s a bug in UE4 as using the console cmds worked fine :slight_smile:

-The prob was that when I went to apply changes to the graphics, nothing actually changed, it basically stayed on the engine settings.