Game preview (standalone) is different from Game Launch (also .uproject file not updating)

I’m building a scene strictly for creating a skybox for an AR project using Ansel as a panoramic screen capture.

Something about UE5 doesn’t let you use Ansel while running the game via the editor, but for some reason it is possible when you have the editor closed, right-click the .uproject file, and select “Launch Game.”

But yesterday I ran into an enormous issue where using Launch Game is running something from a week and a half ago—textures are wrong, assets missing; in one case the entire skybox is gone.

When I run the game in standalone, everything is present and working and updated as you would expect—but the .uproject file is stuck at some point in the past and saving the project does not update that file. I don’t know if that’s related, but as the .uproject file itself is only 3kb and is basically a list of switches, I can’t see how that would influence such specific details in the game.

I’m at my wits’ end. Can anyone help me through this…?