Game not working on android device

Hello ,

I have successfully deployed my game on an android device for testing. When I launch it from the app drawer , it opens for a second and then closes automatically.

The Android Device Monitor logcat file is here → Monitor Log file

This is the device_logcat file → logcat

I am really stuck here and cannot move forward until I test my game.

Also when I package my game for 64-bit windows and try to run it I get an error saying," Access violation : trying to read location : ----- "

Any kind of help is welcome.

Thank you for responding Chris.
The size of of OBB on my system is 24 , 41 , 441 KB. Yeah , I don’t know whether it should be this huge.

When I check my device it shows that the app is of 152 MB.

So I did as you said. I made a FPS blueprint project and installed the apk on my device. It worked absolutely fine.

Then I read the Unreal Documentation reducing the size of the APK , which really really helped me reducing the size of my OBB file from 2.6GB to 39 MB.

But the game is still 153 MB on the device which is strange.
And most importantly it is still not working. The splashscreen appears for 5 seconds and then the game crashes.
I am attaching the new logcat files.

Device LogCat->lfile

Unreal filtered Log file->file

Can somone help me here as I am unable to launch my game without testing it.

are you using vulcan?
hace you tried without vulcan?

the log cat can you filter it with your app?

No I am not using Vulcan. And the FPS template I tried to install worked well with the same project settings that I am using now.
By filtering the logcat with the the app , you mean the app name.

I tried to shift my project to a blank C++ project.
Here is the new log cat file.

Device Log cat->file

Unreal Filtered Log cat → file

If people from Unreal or anyone can help. It is my first time with Unreal and game development and I don’t want to get demotivated.

And I am posting some screen shots of the logcat where I felt it could be erroneous .

Screnshoots shows nothing.better post txt. And checkout the part of fatal error

I have already posted the logcat files in the comment before the screenshot one.

I’ve never developed for Android but are you using any plugins with the engine? If you are, I’d suggest you disable them, repackage and try to load the game and if it loads without the plugins, then turn them back on one at a time until you find the one causing the problem.

If you open your device logcat file in your browser and then hit CRTL+F to bring up the search and type in “error” as the search term, you’ll see there’s 145 times where the word error shows up. A lot of them seem to be the same error

07-30 22:28:30.952   362   362 D SFPerfTracer:        layers: (6:24) (FocusedStackFrame (0xb7fb1318): 0:1383)* (DimLayer (0xb8068170): 7:260) (DimLayer (0xb8044058): 0:2)* (StatusBar (0xb8047638): 0:32222) ( (0xb8026960): 0:2884) (DimLayer (0xb802c7a8): 0:353)* (DimLayer (0xb807ef18): 0:54)* (NavigationBar (0xb8072090): 0:78) (Starting com.YourCompany.Chipards (0xb8009590): 0:26)- (ScreenshotSurface (0xb7fe0be0): 0:16)- (BlackSurface (0xb802b210): 0:16)- (BlackSurface (0xb807bd80): 0:16)- (BlackSurface (0xb7fe2d28): 0:16)- (BlackSurface (0xb7fdd660): 0:16)- (com.YourCompany.Chipards/com.epicgames.ue4.GameActivity (0xb80789b8): 0:12)- (com.YourCompany.Chipards/com.epicgames.ue4.GameActivity (0xb7fe0be0): 0:7)- (SurfaceView (0xb802b210): 0:6)- (ScreenshotSurface (0xb8009590): 0:15)- ( (0xb7fe2d28): 0:18) (Application Error: com.YourCompany.Chipards (0xb802b210): 19:40) (BlackSurface (0xb7fe0be0): 0:15)- (BlackSurface (0xb80745c8): 0:15)- (BlackSurface

No I am not using any plugins.

Here is the error that matters:

Assertion failed: FileLength >= kEOCDLen [File:D:\Build++UE4+Release-4.15+Compile\Sync\Engine\Source\Runtime\Core\Private\Android\AndroidFile.cpp] [Line: 577]

Looks like you have a corrupt OBB file (/storage/emulated/0/Android/obb/com.YourCompany.Chipards/

This particular check makes sure the file is at least 22 bytes long which is the size of the header with location of the directory (an OBB is an uncompressed ZIP file). What size is the OBB on your system and what size is it on device?

I’m not sure what you mean by 24 , 41 , 441 KB. How many bytes is that? OBB is limited to 2GB maximum. If the OBB is too large, did you include too much content? I recommend trying something simple to start like First Person BP template without starter content just to see if you can get something working.