Download

Game mode possessing the wrong actor

Hello all,

Before you point me to other threads, please read. I have spent a couple days searching documentation, as well as rewording the search criteria. Everything I have searched points to the same information.

I am fairly new, this is just a hobby for me. I have successfully made and created blueprint levels. I have some experience with C++, so I started to delve into that area in the engine.

I created a Third Person Blueprint Project, for the bulk of my level. I started with creating a C++ third person character, following the Unreal Engine tutorial document. Everything compiles and passes. I deleted the default Third Person Character from the world. Added mine.

I made sure my actor was set to level zero and using the ThirdPersonGameMode. I changed the settings in World Settings and Project Settings/Maps and Modes and made sure they were pointing to the right blueprints.

I do have a Player Start actor in my level. The Spring Arm and Camera are correctly placed.

When I press play, It possesses a camera far from my character, when I turn around it is a camera. And first person view. It shows in the game mode World Outliner, but, my Third Person character disappears from World Outliner and the level where I placed it. And I can’t possess my character in game mode using F8. Or by right clicking the camera actor that is possessed to change to my character.

I have a feeling that it is possessing the original camera from the project at creation, that I deleted from the level. I can’t find where it is to disable it and it doesn’t show in the World Outliner in Edit Mode.

If you need additional information I’d be glad to provide what I can. And thank you for your help.

Upon reading more posts, I thought it might have been a collision with the SpringArm issue. Testing this didn’t change any results.

I also tried using the default Third Person pawn setting it to zero and reset all the settings to use this as my default pawn. This pawn is having the same issue now. And I can’t replicate this in a new project. I’ll try this in a blank project see if I can get it to work.

A little bit of an update.

I figured out what was happening during play mode. When I was changing the settings and compiling the default input setting wasn’t saving. I had to Reset the default back to zero, compile/save. close the engine and restart the engine. Oddly, in the character blueprint the input default was still set to zero, but, it needed to be compiled and saved as if I hadn’t done that before I closed the engine.

But, that works now at least. On to a new issue haha, Mouse look works but move forward, Move Right and Jump don’t work.

back to reading a ton of posts again lol.

Thanks for all your help!