Download

Game Mode / Controller on Open Level

Hey all,

I current have two different levels, one of which I set up a different game mode and controller that makes my camera’s rotation follow my mouse position.

Once I have selected a view text with that first level, I want to switch to unreal’s first person camera in a different level by using Open Level in blueprint.

The problem I am having with that, is the level opens fine but the first person camera controller will not follow my mouse anymore. The game mode and all objects

from the game mode in the previous scene are all still in the world. Does anyone know how to fix this problem, or a way of going about it?

Here is a video for a visual representation that is happening https://drive.google.com/open?id=0B_9Ecw6gXAPZRWtxbzNCdk5iaEk

In the level with the error open the world detail settings and make sure you have override the first game mode with you’re new game mode and settings

Sorry for my extremely late reply, I did not notice anyone replied.

As to your solution, I have tried that. But the Game Mode that is in the first level seems to override my world setting in the next level I opened. :\

Hello no worries can you post screen shots of the following so I can try and assist you further
As it’s a bit difficult just from the video alone

  1. you’re gamemode settings in projects settings maps and modes

  2. the game mode overide settings on each map

  3. the blueprint where you are changing the level.

Absolutely! Here is a link to all the pictures in google docs. I was struggling to upload all three on here for whatever reason, my apologies.

https://drive.google.com/drive/folders/0B5O4v4WmO27xbDE1X1RpNHFRYnc?usp=sharing

im confused in the video you showed the level with some cubes and staires but i dont see the settings for that in the pictures you linked or was that number 2??

and also can i see the blueprint logic for the level with the writing espcecially the bit where you are calling the nodes to switch level

thanks

Hi EniGmaa, yes the cube level was just a test level.

I actually just figured out what my problem was today, it had nothing to do with my Game Mode.
In my blueprints, I am setting the Character Controller to InputGameandUI on start of the sequence.

However, before I change or Open a new level, I must make the Character Controller’s Input to Game Only.

Thank you so much for your help, I greatly appreciate it :slight_smile:

Well done glad you figured it out. Sometimes this is the best way as you will learn a lot more than being given the answers.

Yeah looking at the two different player controllers was going to be the next suggestions after looking at how you were switching levels.

One thing I did notice though is that in one of the screen shots you linked you were overriding the game mode with the game mode that was already in you’re project settings . This isn’t needed

The way it works is this . If you do not use any game mode overrides then by default all levels will inherit the default gamemode from the project settings . You only need to use the override settings if you want a level to change.

For example let’s say I have 4 maps . I want 3 maps to have the gamemode ‘test’ and 1 map to have the gamemode ‘test2’

I would simply put ‘test’ gamemode as the default game mode in project settings . This now means that all 4 maps would start with ‘test’ gamemode then I simply open the 1 level that u want to have ‘test2’ gamemode and put ‘test2’ gamemode into the overide section

Result is 3 maps inherit the default ‘test’ gamemode 1 map overrides ‘test’ gamemote and replaces it with ‘test2’

Not sure if this was just a mistake or if you didn’t know so thought I would explain it .

Anyway nice to meet you if you need anymore help I’m normally always lurking lol

I know this is super old, but I wanted to comment with what worked for me in case others have trouble with it.

In my HUD widget (I was working on a simple main menu that lets me choose game modes), I used Open Level to load the level and added this as a parameter in the options input:

?Game=/Game/Player/Blueprints/ThirdPersonGameMode.ThirdPersonGameMode_C

Don’t be fooled, the _C at the end will not be in the name of your game mode. If it is, you might need another _C at the end. Nothing anywhere in the gamemode/files has an _C at the end, but as game mode is a class, it seems the engine automatically suffixes it with _C.

@Nostrildumbass

Thanks for your tip on “ThirdPersonGameMode.ThirdPersonGameMode_C”