Game mode change problem

first, im using translate, so little weird english,
Now, I am making a function that makes the level into a sub-level, then creates a title level, and starts the game as the level changes when the start button is pressed there.
When you open the level by pressing the button, you are still stuck in the game mode of the title.
Even if you set it separately in the level or set it in the project settings, the title game mode is still maintained, but I don’t know how to do this part.
Any help would be appreciated.

If you are clicking a button to go from a title/menu gameworld to an actual gameplay level, and you are loading that new level, just make sure that level is set to run with a different GameMode. You don’t need to specify anything else. The OpenLevel node will just do it for you. In that level go to its WorldSettings and choose the GameMode you need.

I set a different game mode for each level, but it still doesn’t change when I press the actual button. Are there any other settings that I haven’t set? Or is it correct that if you set one in the level, it will change automatically, but my engine is a little weird?
Here, even if you press the button in the title, the game mode does not change while it is fixed.

This is the game mode in the editor, not in-game.
Each is a title and a main stage.



Ok, take a look again at the picture you sent me of your “main stage” with the red background… it says the ‘Selected GameMode’ is TitleModeBP!!! It’s the wrong GameMode. Before beginplay when you are in your game level (the red one), in its world settings make sure GameModeBP is selected as the override. It should be that one when you hit play. It shouldn’t change…

I am reading again your comment to understand better. If the drop-down list does not let you change… then that’s another weird issue. Maybe level corrupt?
Also, try not using those specifiers in the node (no paths, try unticking ‘Absolute’) etc.

First, I tried to play the game again after disabling the Absolute and Option settings as in the answer, but the problem was not resolved.
As before, if you press the start game button in the title, the titlegamemodeBP is maintained.


Ok, maybe there is some other logic somewhere that you are not showing. Is this entirely Blueprint based? Or is there code? In the first post you said ‘you have a function that makes a level into a sub-level’ etc. What does that mean? Can we see it?


Thank you so much for helping out like this.
In the case of the level, we are adjusting it using the level design features provided by Unreal Engine by default. And the above process is all done in blueprint, there is no set source code. i.e. it works entirely as a blueprint only.
I’ve tried other engine versions as well, and I get the same results.

Oh… now I get it. Sorry, so you’re saying your main01 map/level, is a sublevel of your Title (menu) map (sorry, the Japanese - or Korean? - text doesn’t help!). It’s peculiar but don’t be confused with how the WorldSettings look. The main level is still your title level, so that’s what the world settings will show. But the loaded sublevel will have its own gamemode as you have defined it. Have you tested with some simple logic to verify that it is your main level’s gamemode that is active? (say, a debug print string every tick or something very obvious like that).

Actually, when the level changes, I tried to get the current game mode and print it out using a Blueprint with a function like beginplay…
Actually, the game mode I set came out as it was. However, there is a problem that changes cannot be made in the editor, so I am not sure if this is a problem with the engine or my personal settings.
I am attaching a picture to help you understand.
When I check the tick, it says the game mode has changed, but when I actually play it, nothing happens.

ok, so you have the correct gamemode as you have specified. The logic that you have defined in that game mode (if any) should be the one that applies. I don’t understand what you mean by nothing happens. You should check your game logic elsewhere in your blueprints. But I would consider this topic as ‘Resolved’ because your game mode does in fact change.

When nothing happens, it actually says that the blueprint changes, but it doesn’t change in the editor world setting next to it, so it doesn’t actually play.
There seems to be some confusion in the words.
Anyway, thanks for the long reply. I’ll have to look for some more.