Download

Game launches, but stops after splashscreen (AndroidEGL seems to be the problem). 4.26.1

Hi, I’m consistently having packaged or launched projects failing to load beyond the splash screen. I was working on something based on the twinstick template, but also tried with the tps template, targeting mobile and quality to scalable.
I’ve tried with a completely empty scene on launch too, but no luck.
My phone is a 2016 Samsung galaxy, using 5.1.1.
I don’t know much about debugging but installed “mlogcat” and tried to look for myself.

Both app closed with the same error, but I have no idea what it means and how to fix it!
(If there is a better way to get logs or any useful info, tell me.) Thanks for any tip or fix ^^

what phone do you have? i also have crash after unreal splashscreen

My phone is a 2016 Samsung galaxy J3, using 5.1.1.
Splashscreen crashes seems to be very common, but have different origins.
We should have a general thread about this, listing all the possible issues for a splashscreen crash.

I looked at the logs you shared, and the “Assertion failed: !GPUFamily.IsEmpty()” could be the key to our problem.
GPU family is referenced in the android documentation here:
https://docs.unrealengine.com/en-US/…les/index.html
https://docs.unrealengine.com/en-US/…tem/index.html

My project also has a stable unity version, so I wont dig to much into unreal tbf. Tell me if you found anything useful tho!

And also my message was cut in half, I believe the forum doesn’t like emojies.