Game keeps running even after shutdown on Steam

I just upgraded to Unreal 4.15 in the Epic Games Launcher (was using the GitHub source of 4.15 beforehand) and I’ve run into a number of problems. After resolving or hacking them away I uploaded a build of my game on Steam.

First of all, the game is never on focus as soon as it’s open so the user needs to click on the window on the PC to actually hear the sounds and get better performance, but the bigger problem is that the app isn’t marked as closed and Steam has a bunch of problems since the App is still “running”. I should mention that the game is for VR.

Is this something anyone else has noticed? Has it happened before?

Hey GMChris,

  • Have you checked to see if the process is still running if you open up your task manager?
  • How are you closing your game? Are you using a specific menu option or console command?

Have you tried implementing a system where on a key press, you have an Execute Console Command node to execute the “Quit” command? Just to test if this gives you the same behavior.

If the process is not running, I feel that this may be more of an issue on Steam’s end. It might be worth also contacting their support to see if they have any additional suggestions.

Hey, the process was not running after shutdown. I’ve tried to turn it off both using from the PC by pressing the X on the window, and from within SteamVR’s Dashboard. It just doesn’t seem to…inform Steam that it’s been closed?

Feel free to reopen the thread with a comment if Steam support reports that it is not an issue on their end.


Hey Gmchris, I am currently having the same issue where Steam still thinks the game is running even though no processes are. This only happens on some computers. I am on 4.17. Did you ever get it fixed?

Hey Ian,

Just wanted to pop in with a quick suggestion, as I’ve seen this happen before and can’t remember if I’ve shared it with you already over on UDN, but you can try using the Resource Monitor, which should be built into a Windows installation. From there, you can get a more detailed view of which processes are running, and it might provide more insight into this.

If you can let me know exactly what error you’re seeing, and when you’re seeing it pop up (starting the game, trying to connect to a MP lobby, etc) I could look into it further, but one issue that I’ve seen in the past related to this were that something was already running on the port that your game is trying to use. Not sure if it’s the same in your situation but figured I’d chime in in case its helpful.

Hey Sean, thanks for the quick response. You have not shared this with me on UDN.

The error occurs after I quit the game when running through steam, regardless of whether quitting the game from the main menu, or force quitting in task manager. After I quit, Steam still says it is running, even though no tasks related to the game are running in task manager.

What is even weirder is that this occurs on my laptop but not my desktop, even though both computers have similar great specs and are under a year old. I am mystified.

That is really odd that it would only occur on a particular PC. I imagine they are running the same OS?
I haven’t seen the same issue before, but I’m more than happy to continue working with you to see if we can figure it out.

Just to clarify, you’ve already checked the Resource Monitor as well to make sure no Steam-related processes were running and that no ports were still in use?

Finally, are you seeing anything strange in the logs when you’re closing the game (if logs are available)?

Hey Sean,

Yes both are windows 10 64 bit.

The logs are the same on both pcs with everything being shut down. The only interesting thing (which again happens on the PC that works too) is this:

[2017.11.30-02.20.54:795][852]LogHttp: Display: Http module shutting down, but needs to wait on 1 outstanding Http requests:
[2017.11.30-02.20.54:795][852]LogHttp: Display: verb=[POST] url=[{164B5E8F-4B3A-C238-CF59-46BC57C0E90D}&AppID=UEGame.Rocket.Release|067482974316BA5673AD7FB2FB601799|UE4Game&AppVersion=4.17.2-3658906%2B%2B%2BUE4%2BRelease-4.17&UserID=ANON-{514CA1F3-4914-36FD-818E-2689B1771431}||&AppEnvironment=datacollector-binary&UploadType=eteventstream] status=Processing

And I have checked and no Steam-related processes (other than Steam itself) are running. It does take a bit to close (like 10 seconds) but eventually everything gets shutdown and cleaned up, even though Steam still says running.


It sounds like you’re potentially running into an issue reported in Unreal Engine Issues and Bug Tracker (UE-46632)

You should be able to access the UDN issue that is linked in the public tracker. You can post an additional comment on that thread if it sounds similar enough and you would like to follow up with an SME.

Let me know if you have any further questions.

I’m experiencing the same issue with my packaged game. Has there been any updates on this? Did Steam indicate if this was an issue on their end?

I’ve been running into this issue. To kill my wrongfully indicated running game, someone recommended to me to shutdown steam and then rename the following folder: “C:\Program Files (x86)\Steam\appcache” to something else, then restart. This action indeed worked for me without restarting the computer.

Best of luck!