Game gets black screen on certain phones

[link text][1]Hello,

We recently stumbled upon a problem with our game. It’s working fine on most android phones we tried it on, but a couple (a Nexus 6P for example) ends up with a black screen right after the splash screen. We tried to change our packaging settings and looked for errors or warnings in our build with no success so far. I’ve attached a log of both a working log and one the Nexus 6P.

If anyone can spot the problem, we would be very grateful, thank you !

[Black Screen Log][2]
[Working Log][3]

119288-blackscreenlog.txt (4.72 KB)
[3]: 119268-workinglog.txt (48.4 KB)

Apparently a line was missing from the log of the one that’s not working :
Failed to connect to file server at RETRYING in 5s.

I edited the post to put the correct log

So editing the line of code has corrected the issue, Mikhael?

It was only a line in the log that was missing, we tried changing multiple options in the packaging and sdk since I posted here, and we’re always handing up with the same result.

Could you please include the full monitor.bat log, not a filtered one?

  • Attach your phone to the computer
  • Go here: C:\android-sdk-windows\tools
  • Open up Monitor.bat
  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\android-sdk-windows\tools\lib\monitor-x86
  • Open up Monitor.exe
  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they’re highlighted.

  • Could you also let me know whether or not you’re having the same type of trouble if you pushed the Vehicle Advanced template to the Nexus 6P?
  • Have you tested in 4.14.1?

Thank you!

I am another member of the development team and upon upgrading to 4.14.1, our Nexus 6P issue seems to have disappeared! So thank you for the suggestion!

Do you have an idea as to why our project encountered this error? The game was previously working on 4.13, and just stopped working from one day to the next. All we had done was add some text to a data file, which didn’t change any of the settings of the game itself. It was a very strange issue.

Thank you so much for the suggestion to upgrade engine versions!

I’m glad that 4.14.1 has fixed the issue for you. To me, it doesn’t make any sense for 4.13 to work and randomly stop working, so it might have been the files that were added. Typically however, issues from a previous version are usually fixed in an updated release, especially those which hinder a workflow.

Let us know if you have any additional questions, thanks!