Game crashes on playing a webm media file

I am having trouble using the WebMMedia plugin for media playback. I used ffmpeg to convert the .mp4 file to a .webm file.

Commands used:

ffmpeg -i ./myvideo.mkv -c:v vp8 -pass 1 -b:v 4000k -crf 10 -c:a libvorbis -af loudnorm=I=-16:LRA=11:tp=-1.0:print_format=json -f webm NUL
ffmpeg -i ./myvideo.mkv -c:v vp8 -pass 2 -b:v 4000k -crf 10 -c:a libvorbis -af loudnorm=I=-16:LRA=11:tp=-1.0:measured_I=-19.22:measured_LRA=4.80:measured_tp=-3.11:measured_thresh=-29.45:offset=-1.04 -ar 48k -f webm ./myvideo.webm

When I try to play the video, my game crashes with the following error.
Assertion failed: vpx_codec_dec_init_ver(&Context, vpx_codec_vp9_dx(), &CodecConfig, 0, (3 + (3 + (4)))) == 0 [File:D:/Build/++UE4/Sync/Engine/Plugins/Media/WebMMedia/Source/WebMMedia/Private/Player/WebMVideoDecoder.cpp] [Line: 89]

I will have to use WebMMedia plugin since I want to build for Linux.
Can you help me troubleshoot this issue.


Additional info: ffmpeg version 3.4.11-0ubuntu0.1

Did you ever find a solution to this? I’m running into the same bug. Assertion fails on the WebMVideoDecover Line 89. I’ve tried both VP8 and VP9 encoding and I’m using ubuntu as well.

Didn’t figure out anything yet. Have moved to Bink Media Player for playing videos.

What settings did you use to getting Bink working? So far I’ve converted the videos to Bk2 and swapped the players out, however my texture output on linux is just black. Am I missing something?

1 Like

You can follow the instructions given here.

I’m running into the same problem on Ubuntu 18.04. I was suspecting some missing libs but found libvpx5 was installed (and its dependencies). As far as I know, that should be the lib that provides the codecs needed by the WebM Player.
If you guys have solved that webm issue, I would be happy to know about what you found.

Video playback has become an issue in the recent versions of the engine. I used to use VLCMedia, but it has not received updates in years. On UE 4.27 I was playing MP4 using WMFMedia on Windows and if I played the same MP4 files on Linux it would crash. Then, I converted to WebM and it was working on Linux but on Windows crashing!

Thus, I decided to play MP4 on Windows using WMFMedia and WebM on Linux using a conditional and two sets of the same assets:

Now, after the upgrade to 5.1, the situation is still the same. Except on Linux, the WebM playback is also broken. If I play one video, it’s OK. As soon as I play the second one simultaneously, it crashes.

It’s good to hear that you had a successful experience with the webm player on LInux? What Linux distro do you use? Would you mind sharing how you encoded your webm files (e.g. ffmpeg parameters) ?

I get the same issue as the person who opened this thread:
LogCore: Error: appError called: Assertion failed: vpx_codec_dec_init_ver(&Context, vpx_codec_vp9_dx(), &CodecConfig, 0, (3 + (3 + (4)))) == 0 [File:./…/Plugins/Media/WebMMedia/Source/WebMMedia/Private/Player/WebMVideoDecoder.cpp] [Line: 89]
It looks like a codec issue.

Agreed, the media player situation is a deal breaker on Linux!

Finding out that there is only strong support (using WMF) on Windows,
and for Linux zero alternatives.

The WebM Player works just fine inside the editor (even playing multiple videos at the same time), but packed it raises the above mentioned error (UE5.0.3).

The VLC player plugin sounded like a good choice, but it is years old, and not maintained anymore. I’ve talked to the dev who wrote it, and he said he is currently coding a VLC Player Plugin PRO version, but no ETA.

Most of the marketplace plugins also are not supposed to work on Linux.
I’ve read about the Bink alternative, seems need to jump onto this track and give it a try.

Why is Epic officially supporting Linux for Unreal, and then is unable to provide such an existential feature like playing Media files? What a shame!

1 Like