Download

Game built with 4.27 doesn't run on Mac

I tried building an empty game on Mac and run it, but the screen stays blank and become unresponsive. Here is the output on console: log.txt (93.2 KB)
(I used the ‘script’ command to record the log, so it contains some garbage.)

Following is what I did:

  1. Download and Install UE 4.27.0 with Epic Games Launcher.
  2. Create an empty project.
  3. Set Game Default Map on Project Settings.
  4. File > Package Project > Mac
  5. run the build

I noticed some error like below, but I have no idea what is wrong…

LogRHI: Could not open FPipelineCacheFile: …/…/…/UE427Test_Stock/Content/PipelineCaches/Mac/UE427Test_Stock_SF_METAL_SM5.upipelinecache
LogRHI: Display: Failed to open default shader pipeline cache for UE427Test_Stock using shader platform 16.

4.26.2 worked fine for me. Did anyone successfully build a game with 4.27 on Mac?

OS: macOS Big Sur 11.5.2
CPU: 3.5 GHz dual-core Intel Core i7

I did. I’m using your same version as well. Maybe try to change the download folder, if this is your first time running UE. If it isn’t, I can’t help you.

Thanks for your reply! Then, maybe, there should be a problem on my end.
UE 4.26.2 and older versions are working well. But for some reason, only 4.27 doesn’t work. (UE4Editor works, but the game build doesn’t work…)