Download

FYI for Mac Users - El Capitan

Just wanted to let those of you on Macs know that I’m hearing from multiple sources that UE4 doesn’t work under the first beta release of El Capitan. I haven’t tried it myself yet, and will probably hold off on installing it until I hear that UE4 is working on it, but thought I’d try and save somebody the headache.

It is actually working, but I having some trouble to get the UnrealEditor sometimes.

Edit : Btw we have the same family name

Did you do some change on your system/unreal? I tried to launch editor a lot of times but it doesn’t work.

TNX

Well actually the Editor was displaying most of the time when I use the mission control, but I was unable to get the normal launcher to create new project … I did reinstall yosemite.

Yeah, I’m hearing mixed things from different people. Still hesitant to upgrade for now, even though I usually do.

Huh. That’s interesting. It’s not a very common name, at least over here in the states. I’ve only met a couple of LaMarches in my life that I’m not related to.

So any updates? Is there a fix. I’m considering reinstalling

No, the issue still persists on 4.8.1. It seems like some people have had some success with loading existing projects, but I haven’t been so lucky. For now, it seems that your best bet is to migrate back to Yosemite until El Cap is officially supported.

Upgrade to El Capitan??? It’s a dev. preview 1, not even close to worth looking for anything on a normal desktop…

There’s an update for it that came out recently but I did not try UE4 with that update. Originally there was no splash screen just a black box, and the Editor wouldn’t show up, but was running.

Too bad UE4 doesn’t start in ML, was thinking to help it out though, as ML is becoming SL of OSX, with SL gone. :wink:

amigo: Nope, it’s not working on El Cap beta 2 at the moment either. As it stands, the editor window almost never renders for me in 4.8+ (the most common exception is when I actually close a window).

But ultimately, the moral of the story is “use beta builds of operating systems at your own risk.” :stuck_out_tongue:

Edit:
To be clear, the editor -is- running, and can be interacted with. You can even see the tooltips every now and then. It’s just that there’s literally nothing drawn to the screen. <.<

if you compile 4.9 from source, promoted branch, it’ll work on El Capitan, but still, I would not use El Capitan on a main machine. I only have it install on secondary laptop to mess around with metal and would not recommend it if you want to do serious work with Unreal.

Yeah, I’ve got beta 2 on my laptop, and I’m able to launch our project. Seems to mostly work other than occasional drawing glitches, likely caused by the conversion of UIKit drawing to metal somehow not playing nicely with UE4s rendering. I’d holding off on my main machine also, but will keep loading the betas on my laptop out of curiosity.

On the bright side, overall, El Cap seems more stable and feature complete than Yosemite and Mavericks were in beta, so that’s promising.

For us developer working not just on games…
it’s quite a valid option to run a DP as main system. Even millions of developer claim todo not.
I love to learn how the DP versions evolve and to use them before they disappear or just like to experiment with the new SDKs.
And i admit i would like to experiment with Metal on OS X with UE4

If you have problem with mono on El Capitan beta 3
Error: “could not discover the mach TLS offset”

To solve this, I compile mono from master branch

Also remove old mono installation, if you have

And use Unreal Engine from promoted or master branch too

Worked like a charm to get past that error. Thanks!

FYI: If anyone encounters an infinite initialization at 0%, run /Contents/MacOS/UE4Editor in the app’s contents. That should run it via Terminal and finish the initialization process (promoted branch).

When I launch mine it goes to initialising… 10%. Then just stop there. so frustrating…

This occurs with me too: 10% freeze

wondering about your setup guys! It is fine here :blush:

-m

I just tried UE 4.8.3 and the latest OSX El Capitan 10.11 beta 6 and it seems to be working fine. The splash screen is still broken but the editor works just fine.

Out of curiosity, did you try both using an existing project and creating a new project?