Fuzzy/Blurry Widgets and Sprites

Hi,

I seem to be writing more questions than code at the moment.

I have added some sprites and a 3D widget to a character in the game. When I hit the preview button the quality of the image decreases to the point where the text on the widget is illegible and the sprites just look like garbage.

I have looked in to streaming, LOD’s ETC but can not find an answer. I have looked at anti aliasing options, mipmap settings and all sorts and cannot get them to stop looking awful.

Does anyone with experience of either 3D widgets or sprites know if it is a Camera issue, a processing issue, and LOD issue ETC and if there is a fix for it? I don’t mind my game looking a little retro but being able to read the text is a minimum requirement.

Thanks

AAAAAnd this was solved by going to Settings → Engine Scalability Settings and raising the settings to Epic and raising the resolution Scale up to 100%.

being able to read the text is a
minimum requirement

Demanding crowd, eh?

One thing you can do to improve the fidelity of the UI is to change the compression of the images to User Interface 2d:

299008-annotation-2020-04-02-185149.png

Do tell if it changes anything.

Other than that, the quality of widget components leaves a lot to be desired. If a sharp interface is what you’re after, either stick with regular widgets or widgets component in screen space mode. :expressionless:

edit: cross posted, did not see your solution :smiley:

1 Like

Hey thanks for the reply, didn’t know that was a thing in the compression field so learned something new.

I did think about using screen space but it looked less part of the character/scene and more like it was stuck to the screen near where characters were…which I guess is in the name. Maybe if I was going to use an Orthographic view it might have looked okay?

Yeah works out that the preview build is just trying to keep things light and thus it makes everything look shady.

For people who have blurry/pixelated widgets in worldspace with TXAA on: Dupe your widget material, make sure its set to Translucent and Unlit, then tick the Responsive AA tickbox under Translucency.

Don’t know if that bad boy impacts performance or anything, but it certainly seems to get rid of the AA shimmering on 2d widgets in worldspace.

2 Likes

Even better, no need to tick the Responsive AA changing the Translucency Pass to After Motion Blur worked for me

1 Like

This made a decent impact for me. Not perfect but better.

Note, for the lurkers - the settings mentioned in this thread are in the Widget Materials and textures. Remember to duplicate to make any changes.