The goal is to run my game in fullscreen, in my case 1920x1080 pixels on my monitor.
I have 4 levels and a level on start holding the menu.
In every single levelblueprint I connected the event begin play node with an execute console command node to
enable fullscreen. Also I did the same in the my character blueprint.

The result is that the first level (menu) is running in fullscreen, the second in a window, the third level switches back
to fullscreen, the fourth again in a window and the fifth again in fullscreen. Going from a level back to the menu-level (first level) it switches again to a window
(on start of the whole game the menu level is fullscreen!).
I have built all lightmaps and have tried both package ways, development and shipping for Windows.
The result is always the same.
Any ideas ?

Just execute the console command in the first level. Then it should always stay in full screen :slight_smile:

Yes and no: I only have one execute console command in the first level and it works similar to my previous packaged game.
But the fullscreen mode switches on and off with every level I enter, like ping pong. On, off, on, off and so on.

You should only execute the command once, in the menu, like said. The game then stays in fullscreen as long as its running even when you load different levels. If it switches back and forth, you likely have some code somewhere that does that.

I had a similar issue switching from my main game level back to my main menu level… fixed it by putting a temporary level with “Loading…” text on it, and in the BeginPlay blueprint, after setting FULLSCREEN, I use “open level” to load my real Main Menu, that way when I go back to the real main menu from my game level, it doesn’t call FULLSCREEN again.