Fullscreen mode is VR

Hi Wrekk,

You will need to play in standalone mode, then press Alt+Enter with the window focused. Does that work for you? If not, let me know what you are experiencing and I will be happy to help you further.

-Alexander

Hello.

I may be stupid or something, but I can’t seem to not put the game in VR fullscreen when I make the game fullscreen, which is fairly frustrating.

Anyone got any ideas?

EDIT: Some staff seems to have edited my post, and made the title “How can I go into Fullscreen mode for VR?” which is almost the exact opposite of what I wanted to do. I clearly stated “but I can’t seem to not put the game in VR fullscreen”, by which I mean that the game is in Virtual Reality fullscreen, which means there are basically two views on my screen, like if you were wearing the Oculus or something.

That’s what I’ve been doing, and it’s still doing it.
I tried using blueprint to go fullscreen by using the console command “FULLSCREEN” and it’s the same. :frowning:

I’m going to test some stuff here, but I want to make sure I am doing the test with the exact same set up as you for accuracy. Which DK of Oculus are you using? Which version number of the engine are you on when this occurs? Source or Binary? Does the fullscreen work without the Oculus hooked up?

Also, your DxDiag would probably help me with hardware compatibility information.

The Blueprint “Console Command” node has some known limitations, so that may not be helping the issue.

Any additional information may help.

That’s the thing, I’m not even using any VR stuff, I don’t even have any of it, that’s why it confuses me that it goes into VR fullscreen (like, you know, there are basically two screens, it’s kinda hard to explain).

And I’m using version 4.4. Though this happend a while back as well, when I first tried the shooter game example, and tried to fullscreen it, but back then I though it was supposed to happen.

DxDiag

Okay, it seems that you guys have misunderstood, and I’d like to clarify that I’m trying to put my game in a normal fullscreen, WITHOUT the VR stuff. Right now, when I put the game in fullscreen, there are two views on my screen, which should only happen when you’re using VR equipment (which I’m not).

I see what you are saying. Sorry about the misunderstanding. To turn off the Stereo View for VR, can you try entering the command “stereo off” in the console? Let me know if that changes anything for you.

Yeah I just tried that, and it worked. But I’d like it to be the standard, is that possible?

We are not sure why that was set to on by default for you, it is not normally set to VR Stereo unless it is manually switched on. I will keep looking into what may have caused that to prevent it in the future. Let us know if you encounter any other unexpected behavior.