Download

Fullscreen menu

I’m trying to create a fullscreen menu upon the application startup.

therefore i created a UMG widget and designed it:
8b17903cc04de2b3134f24fa26f27572f4f6a6fb.jpeg

and then added it at the level “Begin Play” event:
16550052b319bcf3b764c6a13b8c96c4664a4957.jpeg

The widget shows up, but my problems:

  • The Widget is completely deformed due to some scaling (my device is wider and less high then in the designer)
  • With the “Set desired size” also it does not fill the whole screen

anyone got an idea how i can set the widgets size to the actual resolution?

regards

  • Jakob

Anchors, they do just that: size your widgets. Your hierarchy pic says nothing as you renamed all widgets, classes are no more visible.

If anchors cannot solve your problems you need to resize widgets from blueprints.

If you simply add it to the viewport and do nothing else, the widget will fill the entire viewport. There is no need to force a desired size.

@nawrot:
Im adding a grid to the root and then all other controls onto that grid. i dont think id need any more then that?

@nick:
It does so, but because im working with a different size in the widget editor it scales my UI, so i think the widgets get rendered with the size set in the editor and then rendered to the viewport size which scales it all?

The size in the designer has no impact on the size at runtime, it is only a preview based on the options set in the upper right (Resolution), combined with your DPI curve. You can configure the DPI curve by clicking the gear in the lower right of the designer’s viewport, or in the User Interface area of your project settings. The default curve is just a linear scale based on the shortest side of the resolution of the game’s viewport.

Just set the DPI mode to Horizontal instead of shortest and it seems to show it correctly now…