Fullscreen immersive on Android no longer working

I installed 4.10 preview today and loaded a project I’m working on. I have an LG G2 (Android 5.0.2) which has on screen navigation controls. In 4.9.2 turning on “Enable FullScreen Immersive on KitKat and above” hid those controls, but it’s no longer working with 4.10 – I still see controls. I just wanted to report that.

Hey ,

Could you please provide a sample of what you’re describing? I’ve turned on this option within 4.10 Preview 1 and fullscreen immersive mode is working perfectly fine on .

Are you able to replicate this in a new project, what about on a different device? Is it only that specific project that this occurs in?

Looking forward to hearing back from you, thanks!

I just created a new project using 4.10 Preview 1 and have same problem.

  1. I selected first person template, Mobile / Tablet, Scalable 3D or 2D
  2. In project settings under Android I enabled “Enable FullScreen Immersive on KitKat and above devices”.
  3. I built project, then selected LG G2 under Launch.
  4. on screen controls remained.

I did just discover that if I disable new launch image option then on screen controls do go away. LG G2 is only test device I have with on screen controls.

Hey ,

I set up a project exactly like you had provided to me in your previous comment. I was able to launch project without any trouble with fullscreen capabilities on as I was able to before. I then went to push project to LG G2 and project would not properly work for me, I tried without OBB as well as some Android Devices seem to have trouble with OBB files. Please keep in mind that OS that LG G2 is on here in house is 4.4.2. I also went ahead and tested this project on Nvidia Shield which has buttons also on screen. full immersive worked perfectly fine.

Would you be able to get from your device as well as a video showing buttons not disappearing on your LG G2?


Hi ,

We haven’t heard back from you in a while, so I’m resolving this post for tracking purposes. If you’re still experiencing this issue, please feel free to respond with details requested by above and we can continue assisting. Thanks!

it’s not resolved, I’ve been busy with other responsibilities, but did try it yesterday with Preview 2. Which exactly? Can you provide instructions on that?

You can obtain from your device by going to following filepath: C:\android-sdk-windows\tools and using Monitor.bat. Keep in mind that you will need to select all of lines in order for them to save to text document. Please upload document in you next reply.

If at all possible, please include a screenshot or short video clip of what you’re seeing on your device regarding fullscreen immersive issue.

Looking forward to hearing back from you, thanks! :slight_smile:

Attached is log file and screenshot. This is now with Preview 3. It shows controls during splash screen and when game loads.


Thank you for bringing this to our attention. I have been able to successfully verify this on LG G2 and . I have submitted UE-22880 as bug report for this in . If you have any further questions, please let us know.

Have a great day!

UE-22880 has been fixed by our Android Developer. It should make it into 4.10. Now when you push to a device like LG G2, buttons will disappear, unless you swipe to get them to pop up.