Download

Fresh PC built for dabbling in unreal, fresh install, horrible FPS

Keeping it short, I have a new build, specs below while under load featured in image 3…


Break down of CPU / GPU while under load featured in image 3…

Featured PIE, running at 2680 x 1350…

The image above is a fresh install of unreal 4.25 with the Megascan addon installed, booted straight into First Person Shooter starter content and imported the ferns and rock featured, all are imported with 2k textures.
The highest tri fern is 1,970, the rocks weigh in at 21,886.

Play in editor is running below 19 FPS at this distance to the objects, getting a similar angle in the editor produces marginally better results at 22 fps (I attributed to the screen space being much smaller).

I’m seeking any insights to investigate towards resolving the issue, or known issues that may be effecting the performance with my setup, I am not capable of interpreting the data above and am unable to identify where the bottleneck is occurring, below i’ll list the troubleshooting steps i’ve used…

  • Latest GPU Geforce game ready driver, 445.87
  • Latest chipset INF for the motherboard [10.1.18243.8188]
  • Latest Serial I/O driver for the motherboard [30.100.1915.1]
  • Latest BIOS update F10c
  • Latest update for windows 10 x64
  • Disabled XMP and all other overclocking related settings, bios reset to default

(Possible variable, originally I installed the latest Nvidia studio driver [v 442.92] for my GPU thinking it would be better suited to creative endeavours, once witnessing its performance in UE4 I immediately did a fresh install of Geforce game ready driver 445.87 through Geforce Experience.)

Thanks in advance! :rolleyes:

Where the billboards also imported? With lot of trees without lods and billboard performance will be dismal even on 2080ti. Also 22 fps when near the plant/rock on 1660ti is not that bad!

Thanks for donating your brain power!

The billboards are imported and having just checked them (I had no idea they were being used to be honest), they are being utilized by all the trees via the Billboard material inst.

You make a good point about distances though! I should include some more information regarding that, included are 2 more screenshots of the same scene from different angles.


Running at 36 FPS…


Running at 33 FPS with nothing but clean cut edges in view…

Thanks again for the input!

If top fps is needed in editor, engine should be fed 2080ti or similar!

Perhaps you’re right, I’ll have to seek something abit beefier to offer up to the UE gods in the future!

Hopefully I can squeeze a little more usability out of this setup for the time being, can’t lose faith yet, something has to help! :slight_smile:

LOL
If you need to squeeze performance out of current gpu in Editor then go to Setting button above view-port, under scalability click Engine scalability Settings and there you can adjust quality for lot of things

Cheers!
Ive given that a shot, opened up the VR template to attack this from a different angle and eliminate the assets as a problem.
Set all of Unreals Scalability settings down to LOW

The result is running at 26 FPS, boy golly I hope this GPU can push out more than this! :eek:

Solution!.. Make a new project? :rolleyes:

After compiling an old project with visual studio and loading into this separate project, the same VR scene that was running at 26 fps on LOW is now smooth sailing at 190 on Epic, making a new project still sees the engine running as expected. Old project running off CPU integrated graphics maybe?

However returning to the old project still leaves me at sub 35 FPS in most unreal starter scenes, I wont question the unreal gods in their infinite wisdom and I’ll just move on, thanks for the help along the way!