Fresh mod started with 2 components & item doesn't exist when playing with mod.

Hi there guys,

I recently encountered a strange issue to where my mod (Canna-Ark) was running fine (meaning no crashes) on local play/dedi but it won’t allow me to spawn in any items I added in, nor can I ever find them off the assigned harvestables. No crash occurs at all, no error message, nothing at all as a matter of fact happens. All other items that are originally with the game work fine, but any NEW items are not showing up.

I have added them to the master item list on PrimalGameData_BP_CustomModName, so that’s not the problem.

I also did an experiment to see if it was something wrong with my file structure for the mod or what not; I tried starting a completely BRAND new mod from scratch (literally zero reused bp’s or anything from any other mods I’ve made). I only copied the GenericMod files (the 3) over to the new mod folder and added in my Custom item (again just made a child of the seed I wanted to use as a base bp, and referenced everything correctly, and set it up to be harvest-able off any small bushes that normally give berries. Not only can I not spawn them in via item id, but they don’t drop off of the plant either.

I don’t know what the hell is going on here, but this is very strange and frustrating at this point. I see plenty of people releasing mods using NEW items, etc, so why would I be having this issue? Again, I started the smallest mod possible just to test to see if it would work, and it doesn’t.

Exact steps I took for fresh mod: Copied GenericMod files to new mod folder. Then I made a child BP of Armarberry seeds primalitem. After that I created a child of SeedHarvest_Component and modified it to have the new seed as one of the resources it drops. Added it to the Resource & Masterlist list as well in PrimalGameData. In addition under Remap Resource Components, I put the From as the original SeedHarvest_Component, and the To as the new one (only did this last step recently to test and see if it fixed it, and it actually broke the seed drops from the looks of it, cause none are dropping now). Cooked, uploaded, and then tested only to encounter same problem.

Anyone have any ideas on how to fix? I literally cannot even make a tiny mod that currently works & it’s driving me nuts.

Note: It works FINE in the editor when I spawn them in, but again I cannot when in the actual game via not the Dev Kit.

UPDATE: Thinking for some reason its just refusing to reference my new over ride for Gamedata. Not sure why this would be happening.

UPDATE2: I decided to go into the cooking folder to see if everything was cooking out correctly. It appears as if not, yet AGAIN cause its not even cooking out all the files (what?! I have everything setup correctly…). This is now the second time the up-loader has caused issues like this (if this is truly the culprit, which I think it may be) which is really aggravating. I renamed the ModTools folder and am verifying my installation now. Will update with more info soon.

UPDATE3: Wasn’t the modtools issue, but that is something that really needs to get fixed here soon. Back to my original update, thinking its just refusing to read my PrimalGameData_BP_Customname.


  • Sinari

I’m having this exact issue.

Just different items as i’m wanting to put in some new Bows. One bow is just not enough when you start playing with metal and keratin ect.

Been through the process of creating the files and references multiple times and different ways but still come down to the same issue, it just doesn’t show any changes to in-game.

Test map works like a charm, i can do whatever i want and spawn whatever i want, usually just change the engrams and levels down to zero to test though, but when it comes to playing in-game it just flat out refuses. No crashes or errors that i’ve been able to find or that have stopped me, i just get the bog standard Ark Local Game.

I thought that it was something to do with the level overrides, gamemode overrides or how my mod file structure was placed, but so far i’ve cooked and uploaded maybe 5 different mods that have each been cooked multiple different ways using different items, files structures, references, names, levels ect ect.

But still no luck.

I had the idea to extend the entire weapon range, more bows, axes, swords, shields(if i can), pikes ect. But right now i’m stuck at the basics.

as far as I can tell, and that’s from my limited testing… You basically have to duplicate everything that every item in the game references in your mod, then you’ve got to copy the vanilla gamemode and gamedata files. I think that’s how it works. Which is a shame, because that’s horribly inefficient in terms of mod size.

@OP how do you verify if it is cooking out correctly?

Checking by eye.

This is not correct from my understanding of other peoples mods I have studied on the workshop. For example: Explosive Arrow. It works and has the SAME file structure that I have for my arrow mod. I have attempted to get this thing accomplished dozens of times now dozens of different ways, and it all ends with the same thing, nothing working correctly in game but works fine in editor. And this goes for ANY item that is NEW that I add in. It doesn’t matter if it is the worlds most simplistic mod for Ark or the most complicated, either way it refuses to work. Why is it I have the literal same file structure as him for my mod, but yet it won’t work and his does?

Blah. I’m about ready to say screw this. I’ve spent more time troubleshooting this than I have with pretty much anything ever, and nothing will work for me. Whats the point in me trying to make content for the game when it just plain and simple doesn’t work? I know it’s not me at this point clearly cause Norab is experiencing it as well. Wish we could get this resolved before I get burned out on the literal days of troubleshooting I have spent into just trying to get a single mod out.

PS: I’m also kind of put off at this point cause 2 of my mod idea’s have already been released at this point by people a day ago (I had completed these projects before the updated Dev Kit was even released…and yet here I am still friggen troubleshooting my *** off, unable to come up with a solution, while others aren’t experiencing this issue at all for the most part and getting to mod to their hearts content). Also I’ve spent 95% of my time in the Dev Kit troubleshooting, debugging with a Dev, or cooking/uploading only to have it be screwed up by the uploader a billion times or to have it just not work, so I’m a bit bitter at this point. I’m not hating at all, just very down at the moment due to not being able to get past this roadblock (I HATE HATE HATE not being able to resolve issues that crush Creative Workflow, its probably the biggest buzz kill ever when it comes to content creation).

Before u cook, play In editor see if it even works…

You should re-read this thread if you are mentioning using PIE to test at this point.

You may need to create another copy of the core blueprints you are overriding. Did you do this by right clicking on them and going “create blueprint based on this”?

I only say this as it was causing issues in mine as well, even though my items were definitely there. It looks visually the same now, but actually works.

I stumbled upon this about 2 hours ago;

I noticed that on my PrimalGameData that it’s parent was PrimalGameData_BP instead of PrimalGameData_BP.PrimalGameData_BP_C. I fixed that, but now my mod is refusing to fully cook out. Not sure why but it’s only outputting the GenericMod.umap…le sigh.

I’m like 95% sure that the PrimalGameData parent issue was the culprit as you said.

This I must try when I get back to my home computer.
Although I may need to re-download the entire ArkDevKit again as I might have broke it with GitHub updating. Forked the main folder and wasn’t sure how to update the fork so removed the repository and reforked it.

When i do try this though i’ll post back my results. Might just re-download everything anyway just to make sure that it’s nothing that i’ve changed that could be the issue, and seeing that i have now re-created my mod over 10 times error finding it will only take a moment to recreate anyway :smiley:

36Gb download here i come…

I know exactly how you feel, the mod I’ve been working on works great in PIE (flawless) go to cook/upload and nothing. Hopefully I’m closer to resolving my issues as I’ve been getting some promising results lately from all the troubleshooting I’ve been doing. Definitely gonna put a Tutorial up if there isn’t one put up by the time I’ve released my mod. The game shows promise with how it can be modded but getting that mod cooked/uploaded is the bummer right now.

Yeah, its really just the fact that its the cooking/uploading that is bugging out most of the time it seems. Other than that most of it logically makes sense to me.

Well hopefully everything works out well for you now.