Freezing on Game Main Menu

Hello everyone, I have developed a game with UE4 and uploaded on Steam. Generally, the game works fine for almost everyone but some user’s have reported that they get stuck on the main menu and I have no idea what is causing this. This has never happened to me, and I think most people haven’t had this happen neither. There are many youtubers uploading their gameplay meaning many people don’t get stuck on the menu. One reviewer pointed out to me on Steam that he got stuck on the main menu with no sound at all. What can be causing this? Is this a problem with my game? Or a bug from UE4? I’ll upload my blueprint of the main menu level. I use a blueprint that creates a widget for the menu UI.

If anyone knows anything, please let me know. Thank you.

It’s almost certainly is a bug. What code do you have in the main menu widget?

This is my code for when the widget constructs. It basically checks if the game has a save file already saved on the PC, if it doesn’t then I set the default user game settings and disable the “Continue Campaign” button.

The rest of the code only happens when buttons are pressed, press “Continue Campaign” Button, press “Settings” Button. etc

That looks ok. Where are they getting stuck, in menuBP or MENU?

  1. Thats not a problem because the menu would still be usable and players can click on “Start a new Game”, already tried it by removing the does save game exist node and it didn’t froze.

  2. I only changed the Slot name from “SaveSlot” to “SaveSlot2”, but people having the menu frozen was happening before updating the slot name so thats not a problem.

Idk because it looks like the game immediately freezes. They say the menu is displayed so the widget is created at least. They also mentioned that there is no sound.

Ok, so it’s freezing in MENU, by the sound of it. Can you show all the code in MENU?

Ok. It used to be that if you changed the save game blueprint and then tried to load an old data file, it wouldn’t cast. But I don’t think that’s the case anymore.

Not sure I’m afraid… :-/

The only thing I can see there is that either your save game doesn’t have a good level name, or the save game cast fails. Then the continue button would have no effect.

EDIT: Another question: have you changed the save game structure since you released the game?

EDIT2: I think you’ve changed your save game class, right?

whats the games name so i can see it in action or try to recreate where and when it freezes? or did anyone of them send you a video of it ?

It’s ok man you’ve done enough. Thank you.

You can play the demo here: Ghost of Tomorrow: Chapter 1 by EdLioni
But it’ll be hard to replicate the error since only a small amount of people report the menu error. But if you find anything let me know, thanks a lot man!