Freezing issues when using UE4.10

I’m having some serious issues with my whole computer freezing in UE4, not only when I’m working in the editor, but also when I’m playing games made with UE4 such as Squad and Ark.

When in the editor, the freezes seem to happen when shaders get involved, eg:when compiling shaders. I am currently working on a project that was working fine until I added in a model/material and now it is consistently crashing.

When playing games, they run well for the most part, but I tend to get freezes randomly after a certain period of time.

I have attached my dxdiag log.

link text

Is it possible 4.7 Ghz is too high and its causing the crashing?

That seems pretty unlikely, Maybe somebody from epic could answer that?

I did just find this person having a similar issue to me: Why does UE4 not cooperate well with FX series CPU architecture???!!?? - Community & Industry Discussion - Unreal Engine Forums!!

Hi tanka2d,

We have no idea what is happening with that forum user’s computers as he hasn’t responded to us in a while, but I can say that I use an FX-8350 at home with no issue, so his is likely some other common thread between all his PCs.

Anyways, no, your clock speed isn’t too high. I’m leaning more towards Win10 and drivers not playing nice with the editor. We test on Win10, but not every driver/hardware combo is available to us. Would you be able to check out the 4.11 Preview and let me know if the issues persist there? If so, could you revert back to Nvidia driver version 359.06? I just want to make sure it’s not an issue with the latest Nvidia driver that you’re on.


I’m away for the weekend, but as soon as I get back to my computer on Monday I will test 4.11 as well as some other versions of the engine to see if I can narrow things down.

With the Nvidia driver, it was happening before I updated to the latest driver. I updated just before I ran the dxdiag to see if the driver was the issue.

I gave what you said a try… No dice. :frowning:

Using the 4.11 preview seems to have fixed the crash with my material in my project, however I am still getting compiler crashes which makes me think the issue is still there.

If I open a project from an older version of the engine (lets say the content examples) when the materials are compiling my computer will freeze usually when it has 69-79 files left. Is there anyway I can export a log of these compiles that you could look at?

Have you let the freeze stay there to see if it becomes responsive again? Whether or not it does, could you send me your project logs? If it happens to crash, can you send me the callstack (can be found in your project’s Saved folder or directly from the crashreporter window)?

Had you modified the World Grid Material in a previous engine version? Just a hunch from another support tech.

The computer doesn’t become responsive again after the crash to my knowledge. I also haven’t modified the world grid material.

I have attached the log from the last time I tried to load the content examples project in 4.11.

[link text][1]
[1]: 75060-contentexamples.log (60 KB)

I just realized that you’re on Nvidia driver version 361.43, please revert to 359.06 (Dec. 1 drivers). We have known issues with 361.43, especially with Win10. This is something on Nvidia’s end (and we are in contact with them about it) and won’t be resolved until they fix it with a driver update.

Let me know if that helps.

I did revert, it was one of the first things you suggested… :s

Hey tanka2d,

Apologies for the delay, I’ve been out sick lately. I’ve got a few things for you to check (the oversight in my last response is my bad). Can you check out your system temps for me when working in the editor? Can you also check out our Software Conflicts page and see if anything there helps?


I appear to have fixed the issue. I was getting similar PC freezes when playing the beta for The Division, which is the first non-UE4 game I’ve had issues with.

I looked into the problem further and found this thread about my FX-9590 CPU:

One of the posts there suggested downloading AMD Overdrive and underclocking the CPU cores. I haven’t had an issue since. It isn’t ideal, but it’s working now and that’s all I can ask for.

Thanks for your help . Hopefully this fixes any issues other FX-9590 users might have. :slight_smile:

Hey tanka2d,

Reading that thread, it seems like a good idea may be to upgrade your motherboard. People on there seem to indicate that, because AMD hasn’t really updated their socket types in a long time, there could be overheating issues when plugging this CPU into an older motherboard. SO, I’d start by setting it back to stock clock speeds and checking your temps while the game is running and see what you get. Then it’ll help you determine if you have heating issues.

What kind of cooling solution are you using for your CPU?


I don’t think the motherboard is the issue… It’s brand new and fairly high-end:

I’m still getting freezes but not as often. next time I get one i’ll take a screenshot of my temps in HWMonitor.